Re: [PATCH 27/49] builtin/repack.c: rename various pack_geometry functions
- From
Taylor Blau <me@ttaylorr.com>
- Date
- Oct 7, 2025, 20:38 UTC
- Message-ID
- <aOV6SaGhyHYsU3Bu@nand.local>
- In-Reply-To
- <aNsUnfRPi8cYwGkm@pks.im>
On Tue, Sep 30, 2025 at 01:22:05AM +0200, Patrick Steinhardt wrote:
Show 14 quoted lines
> On Sun, Sep 28, 2025 at 06:08:54PM -0400, Taylor Blau wrote:
> > diff --git a/builtin/repack.c b/builtin/repack.c
> > index 18c3df7200..2ce1ae3364 100644
> > --- a/builtin/repack.c
> > +++ b/builtin/repack.c
> > @@ -115,17 +115,17 @@ struct pack_geometry {
> > int split_factor;
> > };
> >
> > -static uint32_t geometry_pack_weight(struct packed_git *p)
> > +static uint32_t pack_geometry_weight(struct packed_git *p)
>
> This rename is a bit of an oddball as we don't work on a `struct
> pack_geometry` here.Agreed. I made the change because the concept of a pack's "weight" in this instance is tied to the pack_geometry API here, not an intrinsic property of the pack.
Show 13 quoted lines
> > @@ -332,7 +332,7 @@ static void geometry_remove_redundant_packs(struct pack_geometry *geometry,
> > strbuf_release(&buf);
> > }
> >
> > -static void free_pack_geometry(struct pack_geometry *geometry)
> > +static void pack_geometry_release(struct pack_geometry *geometry)
> > {
> > if (!geometry)
> > return;
>
> Okay, this function also gets adjusted for the new naming schema we have
> around free/release. Good, but it might be worth it to point it out in
> the commit message.I wrote the commit message to be generic to cover "various pack_geometry functions". Did you want me to be more specific about which functions were renamed?
Thanks, Taylor