Re: [PATCH v3 4/8] autocorrect: rename AUTOCORRECT_SHOW to AUTOCORRECT_HINTONLY
- From
- Jiamu Sun <39@barroit.sh>
- Date
- Mar 11, 2026, 02:46 UTC
- Message-ID
- <SY0P300MB08013A8975797924A3C908FFCE47A@SY0P300MB0801.AUSP300.PROD.OUTLOOK.COM>
- In-Reply-To
- <CAOLa=ZTBFXZuzxm750w-xsT4e7C3+q6r+hcgyODRVZWjtCtbQA@mail.gmail.com>
On Tue, Mar 10, 2026 at 07:08:52AM -0700, Karthik Nayak wrote:
Show 6 quoted lines
> > [snip] > > I'm not sure if AUTOCORRECT_HINTONLY is any better than > AUTOCORRECT_SHOW. The latter indicates that we show the user something. > Doesn't the former also mean the same?
You are right, it indicates that we show the user something. But show what? A prompt can also contain a message that acts as a "show", and I was quite confused when I first saw this part. On the other hand, HINTONLY has a clear intent, which is "hint".
> If we do decide to go forward with AUTOCORRECT_HINTONLY, can we rename > it to AUTOCORRECT_HINT_ONLY? It's easier to read that way.
AUTOCORRECT_HINT_ONLY breaks the current naming pattern of the mode enum. Maybe we can use "AUTOCORRECT_HINT", as the "only" intent is clear with other enum items.
--
Jiamu Sun <39@barroit.sh>
<sunjiamu@outlook.com>