From: Jiamu Sun <39@barroit.sh> Date: Wed, 11 Mar 2026 02:46:51 GMT Subject: Re: [PATCH v3 4/8] autocorrect: rename AUTOCORRECT_SHOW to AUTOCORRECT_HINTONLY Message-ID: In-Reply-To: On Tue, Mar 10, 2026 at 07:08:52AM -0700, Karthik Nayak wrote: > > [snip] > > I'm not sure if AUTOCORRECT_HINTONLY is any better than > AUTOCORRECT_SHOW. The latter indicates that we show the user something. > Doesn't the former also mean the same? You are right, it indicates that we show the user something. But show what? A prompt can also contain a message that acts as a "show", and I was quite confused when I first saw this part. On the other hand, HINTONLY has a clear intent, which is "hint". > If we do decide to go forward with AUTOCORRECT_HINTONLY, can we rename > it to AUTOCORRECT_HINT_ONLY? It's easier to read that way. AUTOCORRECT_HINT_ONLY breaks the current naming pattern of the mode enum. Maybe we can use "AUTOCORRECT_HINT", as the "only" intent is clear with other enum items. -- Jiamu Sun <39@barroit.sh>