Re: [PATCH v3 4/8] autocorrect: rename AUTOCORRECT_SHOW to AUTOCORRECT_HINTONLY
- From
Karthik Nayak <karthik.188@gmail.com>
- Date
- Mar 10, 2026, 14:08 UTC
- Message-ID
- <CAOLa=ZTBFXZuzxm750w-xsT4e7C3+q6r+hcgyODRVZWjtCtbQA@mail.gmail.com>
- In-Reply-To
- <SY0P300MB080176719022D3D7C2C5D70FCE46A@SY0P300MB0801.AUSP300.PROD.OUTLOOK.COM>
Jiamu Sun <39@barroit.sh> writes:
> AUTOCORRECT_SHOW is ambiguous. Its purpose is to show commands similar > to the unknown one and take no other action. Rename it to fit the > semantics. >
I'm not sure if AUTOCORRECT_HINTONLY is any better than AUTOCORRECT_SHOW. The latter indicates that we show the user something. Doesn't the former also mean the same?
If we do decide to go forward with AUTOCORRECT_HINTONLY, can we rename it to AUTOCORRECT_HINT_ONLY? It's easier to read that way.
[snip]