git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [WIP/PATCH v4 6/8] for-each-ref: rename some functions and make them public

From
Christian Couder <christian.couder@gmail.com>
Date
May 31, 2015, 08:04 UTC
Message-ID
<CAP8UFD080Yuv-CYcDzAG0u6OV7Sqry=0s1HKoJbt5wfKjTNO3Q@mail.gmail.com>
In-Reply-To
<1433008411-8550-6-git-send-email-karthik.188@gmail.com>
On Sat, May 30, 2015 at 7:53 PM, Karthik Nayak <karthik.188@gmail.com> wrote:
>
> -static void sort_refs(struct ref_sort *sort, struct ref_array *array)
> +void sort_ref_array(struct ref_sort *sort, struct ref_array *array)
It is probably better to call the above function ref_array_sort()...
[...]
> -static struct ref_sort *default_sort(void)
> +/*  If no sorting option is given, use refname to sort as default */
> +struct ref_sort *ref_default_sort(void)
... especially since you call the above ref_default_sort()...
> -static int opt_parse_sort(const struct option *opt, const char *arg, int unset)
> +int opt_parse_ref_sort(const struct option *opt, const char *arg, int unset)
... and the above opt_parse_sort().
Previous: Karthik NayakNext: Christian Couder
Message 21 of 44 in “for-each-ref: extract helper functions out of grab_single_ref()”
  1. 1/8 for-each-ref: extract helper functions out of grab_single_ref()Karthik Nayak, May 30, 2015
  2. Eric SunshineMay 31, 2015
  3. Karthik NayakMay 31, 2015
  4. Junio C HamanoMay 31, 2015
  5. Karthik NayakMay 31, 2015
  6. Matthieu MoyMay 31, 2015
  7. Junio C HamanoJun 1, 2015
  8. 2/8 for-each-ref: simplify codeKarthik Nayak, May 30, 2015
  9. 3/8 for-each-ref: rename 'refinfo' to 'ref_array_item'Karthik Nayak, May 30, 2015
  10. Junio C HamanoMay 31, 2015
  11. Karthik NayakMay 31, 2015
  12. 4/8 for-each-ref: introduce new structures for better organisationKarthik Nayak, May 30, 2015
  13. Eric SunshineMay 31, 2015
  14. Karthik NayakMay 31, 2015
  15. 5/8 for-each-ref: introduce 'ref_filter_clear_data()'Karthik Nayak, May 30, 2015
  16. Christian CouderMay 31, 2015
  17. Karthik NayakMay 31, 2015
  18. 6/8 for-each-ref: rename some functions and make them publicKarthik Nayak, May 30, 2015
  19. Eric SunshineMay 31, 2015
  20. Karthik NayakMay 31, 2015
  21. Christian CouderMay 31, 2015
  22. Christian CouderMay 31, 2015
  23. Karthik NayakMay 31, 2015
  24. Christian CouderMay 31, 2015
  25. Karthik NayakMay 31, 2015
  26. Matthieu MoyJun 1, 2015
  27. Karthik NayakJun 1, 2015
  28. Junio C HamanoMay 31, 2015
  29. Junio C HamanoMay 31, 2015
  30. Karthik NayakMay 31, 2015
  31. Junio C HamanoJun 1, 2015
  32. Karthik NayakJun 1, 2015
  33. 7/8 ref-filter: move code from 'for-each-ref'Karthik Nayak, May 30, 2015
  34. 8/8 ref-filter: add 'ref-filter.h'Karthik Nayak, May 30, 2015
  35. Eric SunshineMay 31, 2015
  36. Karthik NayakMay 31, 2015
  37. Eric SunshineMay 31, 2015
  38. Karthik NayakMay 31, 2015
  39. Matthieu MoyMay 31, 2015
  40. Karthik NayakMay 31, 2015
  41. Christian CouderMay 31, 2015
  42. Matthieu MoyJun 1, 2015
  43. Christian CouderMay 31, 2015
  44. Karthik NayakMay 31, 2015

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.