git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [WIP/PATCH v4 6/8] for-each-ref: rename some functions and make them public

From
Karthik Nayak <karthik.188@gmail.com>
Date
May 31, 2015, 19:34 UTC
Message-ID
<556B6234.2010809@gmail.com>
In-Reply-To
<xmqqmw0kab94.fsf@gitster.dls.corp.google.com>
On 05/31/2015 11:18 PM, Junio C Hamano wrote:
Show 43 quoted lines
> Karthik Nayak <karthik.188@gmail.com> writes:
>
>>   /*
>> - * A call-back given to for_each_ref().  Filter refs and keep them for
>> + * A call-back given to for_each_ref(). Filter refs and keep them for
>>    * later object processing.
>>    */
>> -static int grab_single_ref(const char *refname, const unsigned char *sha1, int flag, void *cb_data)
>> +int ref_filter_handler(const char *refname, const unsigned char *sha1, int flag, void *cb_data)
>>   {
>
> I am not sure if this is a good external interface, i.e. to expect
> callers of ref-filter API to do this:
>
> 	prepare cbdata;
> 	for_each_ref(ref_filter_handler, &cbdata);
>
> It might be better to expect callers to do this instead:
>
> 	prepare cbdata;
>          filter_refs(for_each_ref, &cbdata);
>
> i.e. introducing a new "filter_refs()" function as the entry point
> to the ref-filter API.  The filter_refs() entry point may internally
> use ref_filter_handler() that will be file-scope static to ref-filter.c
> and at that point the overly generic "-handler" name would not bother
> anybody ;-) but more importantly, then you can extend the function
> signature of filter_refs() not to be so tied to for_each_ref() API.
> It could be that the internals of cbdata may not be something the
> callers of filter-refs API does not even have to know about, in
> which case the call might even become something like:
>
> 	struct ref_array refs = REF_ARRAY_INIT;
>          const char **ref_patterns = { "refs/heads/*", "refs/tags/*", NULL};
>
> 	filter_refs(&refs, for_each_rawref, ref_patterns);
>
>          /* now "refs" has the result, the caller uses them */
> 	for (i = 0; i < refs.nr; i++)
>          	refs.item[i];
>
> Just a thought.
>
Thats brilliant, How about I introduce something of this sort
int filter_refs(int (*for_each_ref_fn)(each_ref_fn, void *), 
ref_filter_cbdata *cbdata)
{
	return for_each_ref_fn(ref_filter_handler, cbdata);
}
where its the most basic form, and things like
 >
 > 	struct ref_array refs = REF_ARRAY_INIT;
 >          const char **ref_patterns = { "refs/heads/*", "refs/tags/*", 
NULL};
 >
 > 	filter_refs(&refs, for_each_rawref, ref_patterns);
 >
 >          /* now "refs" has the result, the caller uses them */
 > 	for (i = 0; i < refs.nr; i++)
 >          	refs.item[i];
 >

Could be achieved using a simple wrapper around 'filter_refs()' something like this perhaps.

int filter_refs_with_pattern(struct ref_array *ref, int 
(*for_each_ref_fn)(each_ref_fn, void *), char **patterns)
{
	int i;
	struct ref_filter_cbdata data;
	data.filter.name_patterns = patterns;
	filter_refs(for_each_ref_fn, &data);
	refs->nr = data.array.nr;
	for(i = 0; i < refs->nr; i++) {
		/* copy over the refs */
	}
	return 0;
}

Is this on the lines of what you had in mind? If it is, than I could just create a new patch which would make ref_filter_handler() private and introduce filter_refs() as shown.

-- 
Regards,
Karthik
Previous: Junio C HamanoNext: Junio C Hamano
Message 30 of 44 in “for-each-ref: extract helper functions out of grab_single_ref()”
  1. 1/8 for-each-ref: extract helper functions out of grab_single_ref()Karthik Nayak, May 30, 2015
  2. Eric SunshineMay 31, 2015
  3. Karthik NayakMay 31, 2015
  4. Junio C HamanoMay 31, 2015
  5. Karthik NayakMay 31, 2015
  6. Matthieu MoyMay 31, 2015
  7. Junio C HamanoJun 1, 2015
  8. 2/8 for-each-ref: simplify codeKarthik Nayak, May 30, 2015
  9. 3/8 for-each-ref: rename 'refinfo' to 'ref_array_item'Karthik Nayak, May 30, 2015
  10. Junio C HamanoMay 31, 2015
  11. Karthik NayakMay 31, 2015
  12. 4/8 for-each-ref: introduce new structures for better organisationKarthik Nayak, May 30, 2015
  13. Eric SunshineMay 31, 2015
  14. Karthik NayakMay 31, 2015
  15. 5/8 for-each-ref: introduce 'ref_filter_clear_data()'Karthik Nayak, May 30, 2015
  16. Christian CouderMay 31, 2015
  17. Karthik NayakMay 31, 2015
  18. 6/8 for-each-ref: rename some functions and make them publicKarthik Nayak, May 30, 2015
  19. Eric SunshineMay 31, 2015
  20. Karthik NayakMay 31, 2015
  21. Christian CouderMay 31, 2015
  22. Christian CouderMay 31, 2015
  23. Karthik NayakMay 31, 2015
  24. Christian CouderMay 31, 2015
  25. Karthik NayakMay 31, 2015
  26. Matthieu MoyJun 1, 2015
  27. Karthik NayakJun 1, 2015
  28. Junio C HamanoMay 31, 2015
  29. Junio C HamanoMay 31, 2015
  30. Karthik NayakMay 31, 2015
  31. Junio C HamanoJun 1, 2015
  32. Karthik NayakJun 1, 2015
  33. 7/8 ref-filter: move code from 'for-each-ref'Karthik Nayak, May 30, 2015
  34. 8/8 ref-filter: add 'ref-filter.h'Karthik Nayak, May 30, 2015
  35. Eric SunshineMay 31, 2015
  36. Karthik NayakMay 31, 2015
  37. Eric SunshineMay 31, 2015
  38. Karthik NayakMay 31, 2015
  39. Matthieu MoyMay 31, 2015
  40. Karthik NayakMay 31, 2015
  41. Christian CouderMay 31, 2015
  42. Matthieu MoyJun 1, 2015
  43. Christian CouderMay 31, 2015
  44. Karthik NayakMay 31, 2015

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.