Re: [WIP/PATCH v4 3/8] for-each-ref: rename 'refinfo' to 'ref_array_item'
- From
Junio C Hamano <gitster@pobox.com>
- Date
- May 31, 2015, 17:37 UTC
- Message-ID
- <xmqqr3pwabsb.fsf@gitster.dls.corp.google.com>
- In-Reply-To
- <1433008411-8550-3-git-send-email-karthik.188@gmail.com>
Karthik Nayak <karthik.188@gmail.com> writes:
> Rename 'refinfo' to 'ref_array_item' as a preparatory step for introduction of new structures in the forthcoming patch. > > Re-order the fields in 'ref_array_item' so that refname can be > eventually converted to a FLEX_ARRAY.
Not a big enough deal to require a reroll, but I think it would be easier to read if this reordering is done in the same patch that makes refname[] into a flex array.