git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [WIP/PATCH v4 4/8] for-each-ref: introduce new structures for better organisation

From
Karthik Nayak <karthik.188@gmail.com>
Date
May 31, 2015, 08:16 UTC
Message-ID
<556AC345.2070101@gmail.com>
In-Reply-To
<CAPig+cSj8Ri=cz9gt_MmMcQQg7iH1beweKfrvEL3MExDY_EiKg@mail.gmail.com>
On 05/31/2015 08:44 AM, Eric Sunshine wrote:
Show 83 quoted lines
> On Sat, May 30, 2015 at 1:53 PM, Karthik Nayak <karthik.188@gmail.com> wrote:
>> Intoduce 'ref_filter_cbdata' which will hold 'ref_filter'
>
> s/Intoduce/Introduce/
>
>> (Conditions to filter the refs on) and 'ref_array' (The array
>
> s/Conditions/conditions/
> s/The/the/
>
>> of ref_array_items). Modify the code to use these new structures.
>>
>> This is a preparatory patch to eventually move code from 'for-each-ref'
>> to 'ref-filter' and making it publically available.
>
> s/publically/publicly/
>
>> Mentored-by: Christian Couder <christian.couder@gmail.com>
>> Mentored-by: Matthieu Moy <matthieu.moy@grenoble-inp.fr>
>> Signed-off-by: Karthik Nayak <karthik.188@gmail.com>
>> ---
>> diff --git a/builtin/for-each-ref.c b/builtin/for-each-ref.c
>> index e634fd2..ef54c90 100644
>> --- a/builtin/for-each-ref.c
>> +++ b/builtin/for-each-ref.c
>> @@ -85,7 +99,7 @@ static struct {
>>    * a "*" to denote deref_tag().
>>    *
>>    * We parse given format string and sort specifiers, and make a list
>> - * of properties that we need to extract out of objects.  ref_array_item
>> + * of properties that we need to extract out of objects. ref_array_item
>
> Sneaking in whitespace change?
>
>>    * structure will hold an array of values extracted that can be
>>    * indexed with the "atom number", which is an index into this
>>    * array.
>> @@ -1076,12 +1085,12 @@ static char const * const for_each_ref_usage[] = {
>>
>>   int cmd_for_each_ref(int argc, const char **argv, const char *prefix)
>>   {
>> -       int i, num_refs;
>> +       int i;
>>          const char *format = "%(objectname) %(objecttype)\t%(refname)";
>>          struct ref_sort *sort = NULL, **sort_tail = &sort;
>>          int maxcount = 0, quote_style = 0;
>> -       struct ref_array_item **refs;
>> -       struct grab_ref_cbdata cbdata;
>> +       struct ref_filter_cbdata ref_cbdata;
>> +       memset(&ref_cbdata, 0, sizeof(ref_cbdata));
>>
>>          struct option opts[] = {
>
> Declaration (struct option opts[]) after statement (memset). I think
> you want to leave the memset() where it was below.
>
>>                  OPT_BIT('s', "shell", &quote_style,
>> @@ -1119,17 +1128,14 @@ int cmd_for_each_ref(int argc, const char **argv, const char *prefix)
>>          /* for warn_ambiguous_refs */
>>          git_config(git_default_config, NULL);
>>
>> -       memset(&cbdata, 0, sizeof(cbdata));
>> -       cbdata.grab_pattern = argv;
>> -       for_each_rawref(grab_single_ref, &cbdata);
>> -       refs = cbdata.grab_array;
>> -       num_refs = cbdata.grab_cnt;
>> +       ref_cbdata.filter.name_patterns = argv;
>> +       for_each_rawref(grab_single_ref, &ref_cbdata);
>>
>> -       sort_refs(sort, refs, num_refs);
>> +       sort_refs(sort, &ref_cbdata.array);
>>
>> -       if (!maxcount || num_refs < maxcount)
>> -               maxcount = num_refs;
>> +       if (!maxcount || ref_cbdata.array.nr < maxcount)
>> +               maxcount = ref_cbdata.array.nr;
>>          for (i = 0; i < maxcount; i++)
>> -               show_ref(refs[i], format, quote_style);
>> +               show_ref(ref_cbdata.array.items[i], format, quote_style);
>>          return 0;
>>   }
>> --
>> 2.4.2
Will change these, thanks!
-- 
Regards,
Karthik
Previous: Eric SunshineNext: Karthik Nayak
Message 14 of 44 in “for-each-ref: extract helper functions out of grab_single_ref()”
  1. 1/8 for-each-ref: extract helper functions out of grab_single_ref()Karthik Nayak, May 30, 2015
  2. Eric SunshineMay 31, 2015
  3. Karthik NayakMay 31, 2015
  4. Junio C HamanoMay 31, 2015
  5. Karthik NayakMay 31, 2015
  6. Matthieu MoyMay 31, 2015
  7. Junio C HamanoJun 1, 2015
  8. 2/8 for-each-ref: simplify codeKarthik Nayak, May 30, 2015
  9. 3/8 for-each-ref: rename 'refinfo' to 'ref_array_item'Karthik Nayak, May 30, 2015
  10. Junio C HamanoMay 31, 2015
  11. Karthik NayakMay 31, 2015
  12. 4/8 for-each-ref: introduce new structures for better organisationKarthik Nayak, May 30, 2015
  13. Eric SunshineMay 31, 2015
  14. Karthik NayakMay 31, 2015
  15. 5/8 for-each-ref: introduce 'ref_filter_clear_data()'Karthik Nayak, May 30, 2015
  16. Christian CouderMay 31, 2015
  17. Karthik NayakMay 31, 2015
  18. 6/8 for-each-ref: rename some functions and make them publicKarthik Nayak, May 30, 2015
  19. Eric SunshineMay 31, 2015
  20. Karthik NayakMay 31, 2015
  21. Christian CouderMay 31, 2015
  22. Christian CouderMay 31, 2015
  23. Karthik NayakMay 31, 2015
  24. Christian CouderMay 31, 2015
  25. Karthik NayakMay 31, 2015
  26. Matthieu MoyJun 1, 2015
  27. Karthik NayakJun 1, 2015
  28. Junio C HamanoMay 31, 2015
  29. Junio C HamanoMay 31, 2015
  30. Karthik NayakMay 31, 2015
  31. Junio C HamanoJun 1, 2015
  32. Karthik NayakJun 1, 2015
  33. 7/8 ref-filter: move code from 'for-each-ref'Karthik Nayak, May 30, 2015
  34. 8/8 ref-filter: add 'ref-filter.h'Karthik Nayak, May 30, 2015
  35. Eric SunshineMay 31, 2015
  36. Karthik NayakMay 31, 2015
  37. Eric SunshineMay 31, 2015
  38. Karthik NayakMay 31, 2015
  39. Matthieu MoyMay 31, 2015
  40. Karthik NayakMay 31, 2015
  41. Christian CouderMay 31, 2015
  42. Matthieu MoyJun 1, 2015
  43. Christian CouderMay 31, 2015
  44. Karthik NayakMay 31, 2015

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.