From: Karthik Nayak Date: Tue, 10 Mar 2026 14:08:52 GMT Subject: Re: [PATCH v3 4/8] autocorrect: rename AUTOCORRECT_SHOW to AUTOCORRECT_HINTONLY Message-ID: In-Reply-To: Jiamu Sun <39@barroit.sh> writes: > AUTOCORRECT_SHOW is ambiguous. Its purpose is to show commands similar > to the unknown one and take no other action. Rename it to fit the > semantics. > I'm not sure if AUTOCORRECT_HINTONLY is any better than AUTOCORRECT_SHOW. The latter indicates that we show the user something. Doesn't the former also mean the same? If we do decide to go forward with AUTOCORRECT_HINTONLY, can we rename it to AUTOCORRECT_HINT_ONLY? It's easier to read that way. [snip]