Re: [PATCH v2] completion: add new git_complete helper
- From
Felipe Contreras <felipe.contreras@gmail.com>
- Date
- Apr 16, 2012, 10:49 UTC
- Message-ID
- <CAMP44s0PWAV=nD1xnAFMx8OPby88W2jKwDGtiUFY4LA93D-gAw@mail.gmail.com>
- In-Reply-To
- <20120415213718.GB5813@burratino>
On Mon, Apr 16, 2012 at 12:37 AM, Jonathan Nieder <jrnieder@gmail.com> wrote:
Show 15 quoted lines
> Felipe Contreras wrote: > >> This simplifies the completions, and makes it easier to define aliases: >> >> git_complete gf git_fetch > > Sounds neat. Unfortunately users could already be using a function > with some other purpose named git_complete in their .profile and this > would override it. The completion script has so far stuck to a > limited namespace: > > _git_* (completion functions) > __git_* (everything else, including public interfaces like __git_ps1) > > A name like __git_complete should work, presumably.
Perhaps it's time to avoid the __ prefix for public interfaces; otherwise how would people know they are public?
-- Felipe Contreras