Re: [PATCH] t7406: correct test case for submodule-update initial population
- From
Stefan Beller <sbeller@google.com>
- Date
- Mar 22, 2017, 22:28 UTC
- Message-ID
- <CAGZ79ka_kErObJAuJrvFxnEMsESCr_2jc+RQ1AMuWx_urWs1mQ@mail.gmail.com>
- In-Reply-To
- <20170322222404.jl3smvai2a3r6tzc@sigill.intra.peff.net>
On Wed, Mar 22, 2017 at 3:24 PM, Jeff King <peff@peff.net> wrote:
Show 28 quoted lines
> On Wed, Mar 22, 2017 at 03:12:07PM -0700, Junio C Hamano wrote:
>
>> > sq=\'
>> > test_expect_success '...' '
>> > cat >expect <<-EOF
>> > Execution of ${sq}false $submodulesha1${sq} ...
>> > '
>> >
>> > but I'm not sure if that is any more readable.
>>
>> Yup, my eyes have long learned to coast over '\'' as an idiomatic
>> symbol, but I agree that it is harder to see until you get used to
>> it (and I do not think it is particularly useful skill to be able to
>> spot '\'' as a logical unit, either). ${sq} thing may make it easier
>> to read but I think the one you did in the first quoted part in this
>> reply is good enough.
>
> Sounds good.
>
>> -- >8 --
>> Subject: t7406: correct test case for submodule-update initial population
>>
>> There are three issues with the test:
>>
>> * The syntax of the here-doc was wrong, such that the entire test was
>> sucked into the here-doc, which is why the test succeeded successfully.
>
> This version looks fine except for the repetitious repetition. :)When I wrote it, It sounded more convincing, but we can drop the "successfully".
Thanks, Stefan