Re: [PATCH] t7406: correct test case for submodule-update initial population
- From
Jeff King <peff@peff.net>
- Date
- Mar 22, 2017, 22:09 UTC
- Message-ID
- <20170322220934.ru7wgujbpg5lq2w6@sigill.intra.peff.net>
- In-Reply-To
- <CAGZ79kbFjCQB_k8E1dMVop_EGF6TpnY04U1NV60VmSs1zHOnZw@mail.gmail.com>
On Wed, Mar 22, 2017 at 03:07:45PM -0700, Stefan Beller wrote:
Show 26 quoted lines
> > Neither of those is true, but I think:
> >
> > cat >expect <<-EOF &&
> > Execution of '\''false $submodulesha1'\'' failed in ...
> > EOF
> >
> > is safer and less surprising. The single-quote handling is unfortunate and
> > ugly, but necessary to get them into the shell snippet in the first
> > place. I notice the others tests in this script set up the expect file
> > outside of a block. You could also do something like:
> >
> > sq=\'
> > test_expect_success '...' '
> > cat >expect <<-EOF
> > Execution of ${sq}false $submodulesha1${sq} ...
> > '
> >
> > but I'm not sure if that is any more readable.
> >
>
> If I recall correctly, I made a big fuss about single quotes used correctly when
> writing that patch (which is why I may have lost track of the actual work there)
> to be told the one and only blessed way to use single quotes in our test suite.
>
> Your proposal to use ${sq} sounds good to me, though we did not
> follow through with it for some other reason. I can reroll with that, though.I'm not sure if it's a proposal. I ended it with "I'm not sure if that is any more readable". :)
I mainly care about making sure the interpolation happens inside the test block (i.e., at the top of the quoted section above).
-Peff