Re: [PATCH 00/24] Header cleanups (final splitting of cache.h, and some splitting of other headers)
- From
Elijah Newren <newren@gmail.com>
- Date
- May 9, 2023, 01:31 UTC
- Message-ID
- <CABPp-BErrVUnuDjL73edDpmkKUvs6Ny6cYwvueXw1toB4JcF-Q@mail.gmail.com>
- In-Reply-To
- <xmqqzg6ergdp.fsf@gitster.g>
On Mon, May 8, 2023 at 8:29 AM Junio C Hamano <gitster@pobox.com> wrote:
Show 10 quoted lines
> > "Elijah Newren via GitGitGadget" <gitgitgadget@gmail.com> writes: > > > > hash-ll, hashmap: move oidhash() to hash-ll > > fsmonitor-ll.h: split this header out of fsmonitor.h > > If you are introducing a bunch of -ll suffixed files, wouldn't you > want to either rename them to ll- prefixed, or rename ll-merge to > match them to make things consistent?
Sure, I'm happy to rename ll-merge to merge-ll. I prefer a suffix since it is common to see files sorted by filename (whether by Git or by the shell) and the suffix tends to keep similar-ish files together.