From: Elijah Newren Date: Tue, 09 May 2023 01:31:00 GMT Subject: Re: [PATCH 00/24] Header cleanups (final splitting of cache.h, and some splitting of other headers) Message-ID: In-Reply-To: On Mon, May 8, 2023 at 8:29 AM Junio C Hamano wrote: > > "Elijah Newren via GitGitGadget" writes: > > > > hash-ll, hashmap: move oidhash() to hash-ll > > fsmonitor-ll.h: split this header out of fsmonitor.h > > If you are introducing a bunch of -ll suffixed files, wouldn't you > want to either rename them to ll- prefixed, or rename ll-merge to > match them to make things consistent? Sure, I'm happy to rename ll-merge to merge-ll. I prefer a suffix since it is common to see files sorted by filename (whether by Git or by the shell) and the suffix tends to keep similar-ish files together.