Re: [PATCH v1 2/8] Add a function to update HEAD after creating a commit
On 07/11/17 03:02, Johannes Schindelin wrote:
Show 23 quoted lines
> Hi Junio,
>
> On Tue, 7 Nov 2017, Junio C Hamano wrote:
>
>> Phillip Wood <phillip.wood@talktalk.net> writes:
>>
>>> @@ -751,6 +751,42 @@ int template_untouched(const struct strbuf *sb, const char *template_file,
>>> return rest_is_empty(sb, start - sb->buf);
>>> }
>>>
>>> +int update_head(const struct commit *old_head, const struct object_id *new_head,
>>> + const char *action, const struct strbuf *msg,
>>> + struct strbuf *err)
>>> +{
>>
>> [...]
>>
>> I however do not think update_head() is such a good name for a
>> helper function in the global scope. builtin/clone.c has a static
>> one that has quite different semantics with the same name (I am not
>> saying that builtin/clone.c will in the future start including the
>> sequencer.h header file; I am pointing out that update_head() is not
>> a good global name that will be understood by everybody).Good point, I'll go with the name Dscho suggests if that's OK with you.
Show 10 quoted lines
> Please try to always accompany a "Don't Do That" by a "How About This
> Instead".
>
> In this case, I could imagine that `update_head_with_reflog()` would be a
> better name. If you disagree, I invite you to propose an alternative that
> strikes your liking.
>
> Ciao,
> Dscho
>