git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v2 12/14] Extract some useful pathspec handling code from builtin/add.c into a library

From
Michael Haggerty <mhagger@alum.mit.edu>
Date
Sep 21, 2012, 07:54 UTC
Message-ID
<505C1D27.7080100@alum.mit.edu>
In-Reply-To
<1348170383-15751-13-git-send-email-git@adamspiers.org>
On 09/20/2012 09:46 PM, Adam Spiers wrote:
Show 25 quoted lines
> This is in preparation for reuse by a new git check-ignore command.
> 
> Signed-off-by: Adam Spiers <git@adamspiers.org>
> ---
>  Makefile      |  2 ++
>  builtin/add.c | 95 ++-------------------------------------------------------
>  pathspec.c    | 97 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
>  pathspec.h    |  6 ++++
>  4 files changed, 108 insertions(+), 92 deletions(-)
>  create mode 100644 pathspec.c
>  create mode 100644 pathspec.h
> 
> [...]
> diff --git a/pathspec.h b/pathspec.h
> new file mode 100644
> index 0000000..4ed40a5
> --- /dev/null
> +++ b/pathspec.h
> @@ -0,0 +1,6 @@
> +extern void validate_path(const char *prefix, const char *path);
> +extern const char **validate_pathspec(const char *prefix, const char **files);
> +extern char *find_used_pathspec(const char **pathspec);
> +extern void fill_pathspec_matches(const char **pathspec, char *seen, int specs);
> +extern const char *treat_gitlink(const char **path);
> +extern void treat_gitlinks(const char **pathspec);

It was unfortunate that these functions were not already documented. But now that you are elevating them from static to global functions, it would be great if you would add some comments for them.

(By the way, thanks for the docstrings that you added in an earlier patch.)
This patch is not only moving code around, but also:
* extracting a new function, validate_path()
* changing the signature of validate_pathspec()
* maybe other things?  How is a reviewer to know without examining every
line of the patch?

Each self-contained change should be done in a separate patch. For example, one patch should move the code while making only the minimal changes logically connected to the move (e.g., removing "static" qualifiers). The other changes should be made separate commits.

Michael
-- 
Michael Haggerty
mhagger@alum.mit.edu
http://softwareswirl.blogspot.com/
Previous: Adam SpiersNext: Adam Spiers
Message 47 of 80 in “new git check-ignore sub-command”
  1. 0/9 new git check-ignore sub-commandAdam Spiers, Sep 2, 2012
  2. 1/9 Update directory listing API doc to match codeAdam Spiers, Sep 2, 2012
  3. 2/9 Improve documentation and comments regarding directory traversal APIAdam Spiers, Sep 2, 2012
  4. 3/9 Rename cryptic 'which' variable to more consistent nameAdam Spiers, Sep 2, 2012
  5. Junio C HamanoSep 2, 2012
  6. 4/9 Refactor excluded_from_listAdam Spiers, Sep 2, 2012
  7. Nguyen Thai Ngoc DuySep 4, 2012
  8. 5/9 Refactor excluded and path_excludedAdam Spiers, Sep 2, 2012
  9. Nguyen Thai Ngoc DuySep 4, 2012
  10. Junio C HamanoSep 4, 2012
  11. Nguyen Thai Ngoc DuySep 5, 2012
  12. Junio C HamanoSep 6, 2012
  13. Nguyen Thai Ngoc DuySep 6, 2012
  14. Thiago FarinaSep 6, 2012
  15. Nguyen Thai Ngoc DuySep 6, 2012
  16. Adam SpiersSep 6, 2012
  17. Junio C HamanoSep 6, 2012
  18. 6/9 For each exclude pattern, store information about where it came fromAdam Spiers, Sep 2, 2012
  19. Philip OakleySep 2, 2012
  20. Junio C HamanoSep 2, 2012
  21. Philip OakleySep 2, 2012
  22. Adam SpiersSep 6, 2012
  23. 7/9 Extract some useful pathspec handling code from builtin/add.c into a libraryAdam Spiers, Sep 2, 2012
  24. 8/9 Provide free_directory() for reclaiming dir_struct memoryAdam Spiers, Sep 2, 2012
  25. 9/9 Add git-check-ignoresAdam Spiers, Sep 2, 2012
  26. Nguyen Thai Ngoc DuySep 2, 2012
  27. Adam SpiersSep 2, 2012
  28. Junio C HamanoSep 2, 2012
  29. Nguyen Thai Ngoc DuySep 3, 2012
  30. Junio C HamanoSep 2, 2012
  31. Junio C HamanoSep 3, 2012
  32. 00/14 new git check-ignore sub-commandAdam Spiers, Sep 20, 2012
  33. 01/14 Update directory listing API doc to match codeAdam Spiers, Sep 20, 2012
  34. 02/14 Improve documentation and comments regarding directory traversal APIAdam Spiers, Sep 20, 2012
  35. 03/14 Rename cryptic 'which' variable to more consistent nameAdam Spiers, Sep 20, 2012
  36. 04/14 Rename path_excluded() to is_path_excluded()Adam Spiers, Sep 20, 2012
  37. 05/14 Rename excluded_from_list() to is_excluded_from_list()Adam Spiers, Sep 20, 2012
  38. 06/14 Rename excluded() to is_excluded()Adam Spiers, Sep 20, 2012
  39. 07/14 Refactor is_excluded_from_list()Adam Spiers, Sep 20, 2012
  40. 08/14 Refactor is_excluded()Adam Spiers, Sep 20, 2012
  41. 09/14 Refactor is_path_excluded()Adam Spiers, Sep 20, 2012
  42. 10/14 For each exclude pattern, store information about where it came fromAdam Spiers, Sep 20, 2012
  43. Junio C HamanoSep 20, 2012
  44. Adam SpiersDec 26, 2012
  45. 11/14 Refactor treat_gitlinks()Adam Spiers, Sep 20, 2012
  46. 12/14 Extract some useful pathspec handling code from builtin/add.c into a libraryAdam Spiers, Sep 20, 2012
  47. Michael HaggertySep 21, 2012
  48. 13/14 Provide free_directory() for reclaiming dir_struct memoryAdam Spiers, Sep 20, 2012
  49. Michael HaggertySep 21, 2012
  50. Junio C HamanoSep 21, 2012
  51. 14/14 Add git-check-ignore sub-commandAdam Spiers, Sep 20, 2012
  52. Johannes SixtSep 21, 2012
  53. Junio C HamanoSep 25, 2012
  54. Johannes SixtSep 26, 2012
  55. Junio C HamanoSep 26, 2012
  56. Michael HaggertySep 21, 2012
  57. Junio C HamanoSep 21, 2012
  58. Junio C HamanoSep 21, 2012
  59. Junio C HamanoSep 20, 2012
  60. Junio C HamanoSep 20, 2012
  61. Adam SpiersSep 20, 2012
  62. Junio C HamanoSep 21, 2012
  63. Adam SpiersDec 26, 2012
  64. Junio C HamanoSep 21, 2012
  65. compiler checksAdam Spiers, Dec 16, 2012
  66. Junio C HamanoSep 24, 2012
  67. Nguyen Thai Ngoc DuySep 4, 2012
  68. Junio C HamanoSep 4, 2012
  69. Nguyen Thai Ngoc DuySep 5, 2012
  70. Adam SpiersSep 10, 2012
  71. Adam SpiersSep 10, 2012
  72. Nguyen Thai Ngoc DuySep 10, 2012
  73. Junio C HamanoSep 10, 2012
  74. Junio C HamanoSep 2, 2012
  75. Adam SpiersSep 6, 2012
  76. Adam SpiersSep 7, 2012
  77. Junio C HamanoSep 7, 2012
  78. Document conventions on static initialization and else cuddlingAdam Spiers, Sep 19, 2012
  79. Junio C HamanoSep 19, 2012
  80. Adam SpiersSep 19, 2012

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.