git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 9/9] Add git-check-ignores

From
Adam Spiers <git@adamspiers.org>
Date
Sep 10, 2012, 11:09 UTC
Message-ID
<20120910110928.GA12974@atlantic.linksys.moosehall>
In-Reply-To
<CACsJy8A2-C9xSz2LXt9Ptjxhe++i2vcBSMY-cxJLWUiutajZUQ@mail.gmail.com>
On Tue, Sep 04, 2012 at 08:06:12PM +0700, Nguyen Thai Ngoc Duy wrote:
Show 13 quoted lines
> On Sun, Sep 2, 2012 at 7:12 AM, Adam Spiers <git@adamspiers.org> wrote:
> > --- a/builtin/add.c
> > +++ b/builtin/add.c
> > @@ -273,7 +273,7 @@ static int add_files(struct dir_struct *dir, int flags)
> >                 fprintf(stderr, _(ignore_error));
> >                 for (i = 0; i < dir->ignored_nr; i++)
> >                         fprintf(stderr, "%s\n", dir->ignored[i]->name);
> > -               fprintf(stderr, _("Use -f if you really want to add them.\n"));
> > +               fprintf(stderr, _("Use -f if you really want to add them, or git check-ignore to see\nwhy they're ignored.\n"));
> >                 die(_("no files added"));
> >         }
> 
> String too long (> 80 chars).

You mean the line of code is too long, or the argument to _(), or both? I didn't like this either, but I saw that builtin/checkout.c already did something similar twice, and I wasn't sure how else to do it. Suggestions gratefully received.

Show 17 quoted lines
> > +static const char * const check_ignore_usage[] = {
> > +"git check-ignore pathname...",
> > +"git check-ignore --stdin [-z] < <list-of-paths>",
> > +NULL
> > +};
> > +
> > +static const struct option check_ignore_options[] = {
> > +       OPT_BOOLEAN(0 , "stdin", &stdin_paths, "read file names from stdin"),
> > +       OPT_BOOLEAN('z', NULL, &null_term_line,
> > +               "input paths are terminated by a null character"),
> > +       OPT_END()
> > +};
> 
> You may want to mark help strings ("read file names from stdin" and
> "input paths... null character") and check_ignore_usage[] for
> translation. Just wrap those strings with N_() and you'll be fine. For
> similar changes, check out nd/i18n-parseopt-help on branch 'pu'.
Thanks, I'll do that.
[snipped discussion of "include" / "exclude" which already continued elsewhere]
Show 16 quoted lines
> > +static void check_ignore(const char *prefix, const char **pathspec)
> > +{
> > +       struct dir_struct dir;
> > +       const char *path;
> > +       char *seen = NULL;
> > +
> > +       /* read_cache() is only necessary so we can watch out for submodules. */
> > +       if (read_cache() < 0)
> > +               die(_("index file corrupt"));
> > +
> > +       memset(&dir, 0, sizeof(dir));
> > +       dir.flags |= DIR_COLLECT_IGNORED;
> > +       setup_standard_excludes(&dir);
> 
> You should support ignore rules from files and command line arguments
> too, like ls-files. For quick testing.

You mean --exclude, --exclude-from, and --exclude-per-directory? Sure, although I have limited time right now, so maybe these could be added in a later iteration?

Show 9 quoted lines
> > +static NORETURN void error_with_usage(const char *msg)
> > +{
> > +       error("%s", msg);
> > +       usage_with_options(check_ignore_usage, check_ignore_options);
> > +}
> 
> Interesting. We have usage_msg_opt() in parse-options.c, but it's more
> verbose. Perhaps this function should be moved to parse-options.c
> because it may be useful to other commands as well?
I'll look into it.
Previous: Adam SpiersNext: Nguyen Thai Ngoc Duy
Message 71 of 80 in “new git check-ignore sub-command”
  1. 0/9 new git check-ignore sub-commandAdam Spiers, Sep 2, 2012
  2. 1/9 Update directory listing API doc to match codeAdam Spiers, Sep 2, 2012
  3. 2/9 Improve documentation and comments regarding directory traversal APIAdam Spiers, Sep 2, 2012
  4. 3/9 Rename cryptic 'which' variable to more consistent nameAdam Spiers, Sep 2, 2012
  5. Junio C HamanoSep 2, 2012
  6. 4/9 Refactor excluded_from_listAdam Spiers, Sep 2, 2012
  7. Nguyen Thai Ngoc DuySep 4, 2012
  8. 5/9 Refactor excluded and path_excludedAdam Spiers, Sep 2, 2012
  9. Nguyen Thai Ngoc DuySep 4, 2012
  10. Junio C HamanoSep 4, 2012
  11. Nguyen Thai Ngoc DuySep 5, 2012
  12. Junio C HamanoSep 6, 2012
  13. Nguyen Thai Ngoc DuySep 6, 2012
  14. Thiago FarinaSep 6, 2012
  15. Nguyen Thai Ngoc DuySep 6, 2012
  16. Adam SpiersSep 6, 2012
  17. Junio C HamanoSep 6, 2012
  18. 6/9 For each exclude pattern, store information about where it came fromAdam Spiers, Sep 2, 2012
  19. Philip OakleySep 2, 2012
  20. Junio C HamanoSep 2, 2012
  21. Philip OakleySep 2, 2012
  22. Adam SpiersSep 6, 2012
  23. 7/9 Extract some useful pathspec handling code from builtin/add.c into a libraryAdam Spiers, Sep 2, 2012
  24. 8/9 Provide free_directory() for reclaiming dir_struct memoryAdam Spiers, Sep 2, 2012
  25. 9/9 Add git-check-ignoresAdam Spiers, Sep 2, 2012
  26. Nguyen Thai Ngoc DuySep 2, 2012
  27. Adam SpiersSep 2, 2012
  28. Junio C HamanoSep 2, 2012
  29. Nguyen Thai Ngoc DuySep 3, 2012
  30. Junio C HamanoSep 2, 2012
  31. Junio C HamanoSep 3, 2012
  32. 00/14 new git check-ignore sub-commandAdam Spiers, Sep 20, 2012
  33. 01/14 Update directory listing API doc to match codeAdam Spiers, Sep 20, 2012
  34. 02/14 Improve documentation and comments regarding directory traversal APIAdam Spiers, Sep 20, 2012
  35. 03/14 Rename cryptic 'which' variable to more consistent nameAdam Spiers, Sep 20, 2012
  36. 04/14 Rename path_excluded() to is_path_excluded()Adam Spiers, Sep 20, 2012
  37. 05/14 Rename excluded_from_list() to is_excluded_from_list()Adam Spiers, Sep 20, 2012
  38. 06/14 Rename excluded() to is_excluded()Adam Spiers, Sep 20, 2012
  39. 07/14 Refactor is_excluded_from_list()Adam Spiers, Sep 20, 2012
  40. 08/14 Refactor is_excluded()Adam Spiers, Sep 20, 2012
  41. 09/14 Refactor is_path_excluded()Adam Spiers, Sep 20, 2012
  42. 10/14 For each exclude pattern, store information about where it came fromAdam Spiers, Sep 20, 2012
  43. Junio C HamanoSep 20, 2012
  44. Adam SpiersDec 26, 2012
  45. 11/14 Refactor treat_gitlinks()Adam Spiers, Sep 20, 2012
  46. 12/14 Extract some useful pathspec handling code from builtin/add.c into a libraryAdam Spiers, Sep 20, 2012
  47. Michael HaggertySep 21, 2012
  48. 13/14 Provide free_directory() for reclaiming dir_struct memoryAdam Spiers, Sep 20, 2012
  49. Michael HaggertySep 21, 2012
  50. Junio C HamanoSep 21, 2012
  51. 14/14 Add git-check-ignore sub-commandAdam Spiers, Sep 20, 2012
  52. Johannes SixtSep 21, 2012
  53. Junio C HamanoSep 25, 2012
  54. Johannes SixtSep 26, 2012
  55. Junio C HamanoSep 26, 2012
  56. Michael HaggertySep 21, 2012
  57. Junio C HamanoSep 21, 2012
  58. Junio C HamanoSep 21, 2012
  59. Junio C HamanoSep 20, 2012
  60. Junio C HamanoSep 20, 2012
  61. Adam SpiersSep 20, 2012
  62. Junio C HamanoSep 21, 2012
  63. Adam SpiersDec 26, 2012
  64. Junio C HamanoSep 21, 2012
  65. compiler checksAdam Spiers, Dec 16, 2012
  66. Junio C HamanoSep 24, 2012
  67. Nguyen Thai Ngoc DuySep 4, 2012
  68. Junio C HamanoSep 4, 2012
  69. Nguyen Thai Ngoc DuySep 5, 2012
  70. Adam SpiersSep 10, 2012
  71. Adam SpiersSep 10, 2012
  72. Nguyen Thai Ngoc DuySep 10, 2012
  73. Junio C HamanoSep 10, 2012
  74. Junio C HamanoSep 2, 2012
  75. Adam SpiersSep 6, 2012
  76. Adam SpiersSep 7, 2012
  77. Junio C HamanoSep 7, 2012
  78. Document conventions on static initialization and else cuddlingAdam Spiers, Sep 19, 2012
  79. Junio C HamanoSep 19, 2012
  80. Adam SpiersSep 19, 2012

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.