Re: [PATCH v2 04/12] worktree.c: mark current worktree
- From
Jeff King <peff@peff.net>
- Date
- Apr 21, 2016, 15:13 UTC
- Message-ID
- <20160421151355.GA6200@sigill.intra.peff.net>
- In-Reply-To
- <CAPig+cQkT8vb-OVdS_ALVuDii9njY6BN2FhkXt=CavAfyeO2Fg@mail.gmail.com>
On Thu, Apr 21, 2016 at 10:23:09AM -0400, Eric Sunshine wrote:
Show 7 quoted lines
> > While we're at it, how about renaming it to pathcmp (and its friend > > strncmp_icase to pathncmp)? > > Yes, that seems like a good idea. For anyone familiar with > strcasecmp() or stricmp(), having "icase" in the name makes it seem as > though it's unconditionally case-insensitive, so dropping it from the > name would likely be beneficial.
Seconded (thirded?). I have been caught by this confusion in the past, too.
-Peff