Re: [PATCH v2 04/12] worktree.c: mark current worktree
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Apr 21, 2016, 15:37 UTC
- Message-ID
- <xmqqk2jrt1kz.fsf@gitster.mtv.corp.google.com>
- In-Reply-To
- <20160421151355.GA6200@sigill.intra.peff.net>
Jeff King <peff@peff.net> writes:
Show 12 quoted lines
> On Thu, Apr 21, 2016 at 10:23:09AM -0400, Eric Sunshine wrote: > >> > While we're at it, how about renaming it to pathcmp (and its friend >> > strncmp_icase to pathncmp)? >> >> Yes, that seems like a good idea. For anyone familiar with >> strcasecmp() or stricmp(), having "icase" in the name makes it seem as >> though it's unconditionally case-insensitive, so dropping it from the >> name would likely be beneficial. > > Seconded (thirded?). I have been caught by this confusion in the past, > too.
I agree that strcmp_icase() gives a false impression that it always ignores case differences, but a new name that does not at all hint that it may do icase comparison as necessary will catch me by an opposite confusion in the future.
I have not yet formed a firm opinion if pathcmp() conveys enough hint.