From: Jeff King Date: Thu, 21 Apr 2016 15:13:56 GMT Subject: Re: [PATCH v2 04/12] worktree.c: mark current worktree Message-ID: <20160421151355.GA6200@sigill.intra.peff.net> In-Reply-To: On Thu, Apr 21, 2016 at 10:23:09AM -0400, Eric Sunshine wrote: > > While we're at it, how about renaming it to pathcmp (and its friend > > strncmp_icase to pathncmp)? > > Yes, that seems like a good idea. For anyone familiar with > strcasecmp() or stricmp(), having "icase" in the name makes it seem as > though it's unconditionally case-insensitive, so dropping it from the > name would likely be beneficial. Seconded (thirded?). I have been caught by this confusion in the past, too. -Peff