git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 2/5] t4001-diff-rename: wrap file creations in a test

From
Jeff King <peff@peff.net>
Date
Feb 24, 2016, 10:25 UTC
Message-ID
<20160224102510.GB21152@sigill.intra.peff.net>
In-Reply-To
<1456249498-3232-3-git-send-email-Matthieu.Moy@imag.fr>
On Tue, Feb 23, 2016 at 06:44:55PM +0100, Matthieu Moy wrote:
Show 20 quoted lines
> Signed-off-by: Matthieu Moy <Matthieu.Moy@imag.fr>
> ---
>  t/t4001-diff-rename.sh | 38 +++++++++++++++++++++-----------------
>  1 file changed, 21 insertions(+), 17 deletions(-)
> 
> diff --git a/t/t4001-diff-rename.sh b/t/t4001-diff-rename.sh
> index 2f327b7..bfb364c 100755
> --- a/t/t4001-diff-rename.sh
> +++ b/t/t4001-diff-rename.sh
> @@ -9,7 +9,9 @@ test_description='Test rename detection in diff engine.
>  . ./test-lib.sh
>  . "$TEST_DIRECTORY"/diff-lib.sh
>  
> -echo >path0 'Line 1
> +test_expect_success 'setup' '
> +	cat >path0 <<\EOF &&
> +Line 1
>  Line 2
>  Line 3
>  Line 4

Should we use "<<-" here (and elsewhere) to indent the sample lines? It makes your diff bigger, but I think the end result is much easier to read.

-Peff
Previous: Matthieu MoyNext: Matthieu Moy
Message 7 of 29 in “activate diff.renames by default”
  1. 0/5 activate diff.renames by defaultMatthieu Moy, Feb 23, 2016
  2. 1/5 Documentation/diff-config: fix description of diff.renamesMatthieu Moy, Feb 23, 2016
  3. Jeff KingFeb 24, 2016
  4. Felipe Gonçalves AssisFeb 25, 2016
  5. Matthieu MoyFeb 25, 2016
  6. 2/5 t4001-diff-rename: wrap file creations in a testMatthieu Moy, Feb 23, 2016
  7. Jeff KingFeb 24, 2016
  8. Matthieu MoyFeb 24, 2016
  9. 3/5 t: add tests for diff.renames (true/false/unset)Matthieu Moy, Feb 23, 2016
  10. 4/5 log: introduce init_log_defaults()Matthieu Moy, Feb 23, 2016
  11. 5/5 diff: activate diff.renames by defaultMatthieu Moy, Feb 23, 2016
  12. Junio C HamanoFeb 23, 2016
  13. Matthieu MoyFeb 23, 2016
  14. Jeff KingFeb 24, 2016
  15. Matthieu MoyFeb 25, 2016
  16. Junio C HamanoFeb 23, 2016
  17. Matthieu MoyFeb 23, 2016
  18. Junio C HamanoFeb 23, 2016
  19. 0/5 activate diff.renames by defaultMatthieu Moy, Feb 25, 2016
  20. 1/5 Documentation/diff-config: fix description of diff.renamesMatthieu Moy, Feb 25, 2016
  21. Documentation/diff-config: fix description of diff.renamesMatthieu Moy, Feb 25, 2016
  22. Junio C HamanoFeb 25, 2016
  23. Junio C HamanoFeb 25, 2016
  24. 2/5 t4001-diff-rename: wrap file creations in a testMatthieu Moy, Feb 25, 2016
  25. 3/5 t: add tests for diff.renames (true/false/unset)Matthieu Moy, Feb 25, 2016
  26. 4/5 log: introduce init_log_defaults()Matthieu Moy, Feb 25, 2016
  27. Junio C HamanoFeb 25, 2016
  28. 5/5 diff: activate diff.renames by defaultMatthieu Moy, Feb 25, 2016
  29. Junio C HamanoFeb 25, 2016

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.