Re: [PATCH 5/5] diff: activate diff.renames by default
Junio C Hamano <gitster@pobox.com> writes:
Show 14 quoted lines
> Matthieu Moy <Matthieu.Moy@imag.fr> writes:
>
>> diff --git a/builtin/log.c b/builtin/log.c
>> index 7f96c64..6e34df3 100644
>> --- a/builtin/log.c
>> +++ b/builtin/log.c
>> @@ -103,6 +103,7 @@ static int log_line_range_callback(const struct option *option, const char *arg,
>> static void init_log_defaults()
>> {
>> init_grep_defaults();
>> + git_diff_ui_default_config();
>> }
>
> Why isn't the new function called init_diff_ui_defaults()?Indeed, that's a better name. I changed it.
Show 11 quoted lines
>> diff --git a/diff.c b/diff.c
>> index 2136b69..d5db898 100644
>> --- a/diff.c
>> +++ b/diff.c
>> @@ -168,6 +168,11 @@ long parse_algorithm_value(const char *value)
>> * never be affected by the setting of diff.renames
>> * the user happens to have in the configuration file.
>> */
>> +void git_diff_ui_default_config()
>
> s/()/(void)/; same for the declaration in the header file.
Fixed. 'doing too much C++ and not enough C ;-).
--
Matthieu Moy
http://www-verimag.imag.fr/~moy/