Re: [PATCH 3/4] format-patch: new --resend option for adding "RESEND" to patch subjects
- From
- Dragan Simic <dsimic@manjaro.org>
- Date
- Apr 17, 2024, 21:09 UTC
- Message-ID
- <19d5f3d4c99fc1da24c80ac2a9ee8bf8@manjaro.org>
- In-Reply-To
- <xmqqle5b66sr.fsf@gitster.g>
On 2024-04-17 23:03, Junio C Hamano wrote:
Show 9 quoted lines
> Dragan Simic <dsimic@manjaro.org> writes:
>
>> With all due respect, "--rfc=WIP" looks like a kludge, simply
>> because "--rfc" should, IIUC, be some kind of a fixed shorthand.
>
> I wouldn't use "should" there. In any case, we are not going to add
> unbounded number of --wip, --resend, etc., on top of what we have
> already. Introducing --something={WIP,RESEND,RFC,HACK,...} and
> deprecating --rfc is not something I would object to, though.Good to know, thanks. I'll drop the patches that add "--resend" as a new command-line option, and I'll think a bit about the solution you described as acceptable.