[PATCH 0/4] format-patch: fix an option coexistence bug and add new --resend option
- From
- Dragan Simic <dsimic@manjaro.org>
- Date
- Apr 17, 2024, 03:32 UTC
- Message-ID
- <cover.1713324598.git.dsimic@manjaro.org>
This series fixes a bug that allows --rfc and -k options to be specified together when running "git format-patch". This bug was introduced about eight months ago, but it has remained undetected, presumably because of lacking test coverage. While fixing this bug, also add a test that covers this mutual exclusion, for future coverage.
This series also adds --resend as the new option for "git format-patch" that adds "RESEND" as a (sub)suffix to the patch subject prefix, which eventually produces "[PATCH RESEND]" as the default patch subject prefix. This subject prefix is commonly used on mailing lists to denote patches resent after they had attracted no attention for a while.
Dragan Simic (4):
format-patch docs: avoid use of parentheses to improve readability
format-patch: fix a bug in option exclusivity and add a test to t4014
format-patch: new --resend option for adding "RESEND" to patch
subjects
t4014: add tests to cover --resend option and its exclusivityDocumentation/git-format-patch.txt | 9 +++++-- builtin/log.c | 16 +++++++++--- t/t4014-format-patch.sh | 41 ++++++++++++++++++++++++++++++ 3 files changed, 61 insertions(+), 5 deletions(-)