From: Dragan Simic Date: Wed, 17 Apr 2024 21:09:03 GMT Subject: Re: [PATCH 3/4] format-patch: new --resend option for adding "RESEND" to patch subjects Message-ID: <19d5f3d4c99fc1da24c80ac2a9ee8bf8@manjaro.org> In-Reply-To: On 2024-04-17 23:03, Junio C Hamano wrote: > Dragan Simic writes: > >> With all due respect, "--rfc=WIP" looks like a kludge, simply >> because "--rfc" should, IIUC, be some kind of a fixed shorthand. > > I wouldn't use "should" there. In any case, we are not going to add > unbounded number of --wip, --resend, etc., on top of what we have > already. Introducing --something={WIP,RESEND,RFC,HACK,...} and > deprecating --rfc is not something I would object to, though. Good to know, thanks. I'll drop the patches that add "--resend" as a new command-line option, and I'll think a bit about the solution you described as acceptable.