Re: [PATCH 3/4] format-patch: new --resend option for adding "RESEND" to patch subjects
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Apr 18, 2024, 22:34 UTC
- Message-ID
- <xmqq5xwepafi.fsf@gitster.g>
- In-Reply-To
- <84dcb80be916f85cbb6a4b99aea0d76b@manjaro.org>
Dragan Simic <dsimic@manjaro.org> writes:
>>>> With all due respect, "--rfc=WIP" looks like a kludge, simply >>>> because "--rfc" should, IIUC, be some kind of a fixed shorthand. >>> I wouldn't use "should" there.
> How about introducing "--label=<string>" as the new option,...
I still think --rfc=WIP is a lot more natural and easier to understand, and it is just the matter of how you introduce it. I'll show you how in a separate patch later.
The problem I see with an overly generic word like "label" is that it would mislead readers to say "--label=important" and expect it to appear on an extra e-mail header, not as a part of "Subject:".
But we can do this to get the ball rolling, without bikeshedding what option name to use. Until we find a good name, users can use --rfc=WIP and when we do find a good name, it can be added as a synonym, possibly deprecating --rfc, and if we never agree on a good name, that is fine as well.