Re: [PATCH 2/5] t/test-terminal: avoid non-inclusive language
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Sep 21, 2020, 21:12 UTC
- Message-ID
- <xmqqsgbaeswj.fsf@gitster.c.googlers.com>
- In-Reply-To
- <nycvar.QRO.7.76.6.2009201733510.5061@tvgsbejvaqbjf.bet>
Johannes Schindelin <Johannes.Schindelin@gmx.de> writes:
Show 31 quoted lines
> Hi Junio, > > On Wed, 16 Sep 2020, Junio C Hamano wrote: > >> Junio C Hamano <gitster@pobox.com> writes: >> >> > "Johannes Schindelin via GitGitGadget" <gitgitgadget@gmail.com> >> > writes: >> > >> >> From: Johannes Schindelin <johannes.schindelin@gmx.de> >> >> >> >> In the ongoing effort to make the Git project a more inclusive place, >> >> let's try to avoid names like "master" where possible. >> > >> > The two sides of a PTY are called 'master' and 'slave', and I >> > understand there is a push to move away from these words, but >> > calling one side with an invented name that is used by nobody else >> > in the context of talking about PTY, while keeping the word used to >> > call the other side, would lead to confusion. >> > >> > A better change is to drop "master_" altogether without replacing >> > the word with anything, and call them just "input", "output" and >> > "error". >> >> If we really want to use a replacement word for 'master' instead of >> just dropping, I may be inclined to suggest 'parent', in the hope >> that PTY implementors will start following what Python folks are >> doing, at which time they will give us a synonym for 'slave' method >> called 'child' we can use. > > Good idea!
It is unclear which one of the two you thought a good idea.
Hopefully both are good, but simply dropping "master_" without attempting to replace would probably be better.