Re: [PATCH 08/67] add reentrant variants of sha1_to_hex and find_unique_abbrev
Jeff King <peff@peff.net> writes:
Show 8 quoted lines
>> Hmm, I haven't read any other patches yet (including those which use these
>> new '_to' functions), but I can't help feeling they should be named something
>> like 'sha1_to_hex_str()' and 'find_unique_abbrev_str()' instead. i.e. I don't get
>> the '_to' thing - not that I'm any good at naming things ...
>
> I meant it as a contrast with their original. sha1_to_hex() formats into
> an internal buffer and returns it. But sha1_to_hex_to() formats "to" a
> buffer of your choice.
I think that naming makes perfect sense.