From: Junio C Hamano Date: Wed, 16 Sep 2015 01:32:02 GMT Subject: Re: [PATCH 08/67] add reentrant variants of sha1_to_hex and find_unique_abbrev Message-ID: In-Reply-To: <20150915175027.GA31091@sigill.intra.peff.net> Jeff King writes: >> Hmm, I haven't read any other patches yet (including those which use these >> new '_to' functions), but I can't help feeling they should be named something >> like 'sha1_to_hex_str()' and 'find_unique_abbrev_str()' instead. i.e. I don't get >> the '_to' thing - not that I'm any good at naming things ... > > I meant it as a contrast with their original. sha1_to_hex() formats into > an internal buffer and returns it. But sha1_to_hex_to() formats "to" a > buffer of your choice. I think that naming makes perfect sense.