Re: [PATCH v2 05/27] revision.[ch]: split freeing of revs->commit into a function
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Mar 24, 2022, 04:33 UTC
- Message-ID
- <xmqqa6dgm0l8.fsf@gitster.g>
- In-Reply-To
- <patch-v2-05.27-4c0718b43d7-20220323T203149Z-avarab@gmail.com>
Ævar Arnfjörð Bjarmason <avarab@gmail.com> writes:
Show 9 quoted lines
> +static void release_revisions_commit_list(struct rev_info *revs)
> +{
> + struct commit_list *commits = revs->commits;
> +
> + if (!commits)
> + return;
> + free_commit_list(commits);
> + revs->commits = NULL;
> +}It makes sense to have this as a separate helper, but the original implementation this was lifted from is much easier to follow than this version with an unnecessary rewrite, I would think.
Show 9 quoted lines
> @@ -4080,10 +4090,7 @@ static void create_boundary_commit_list(struct rev_info *revs)
> * boundary commits anyway. (This is what the code has always
> * done.)
> */
> - if (revs->commits) {
> - free_commit_list(revs->commits);
> - revs->commits = NULL;
> - }
> + release_revisions_commit_list(revs);IOW
static void release_revisions_commit_list(struct rev_info *revs)
{
if (revs->commits) {
free_commit_list(revs->commits);
revs->commits = NULL;
}
}