Re: [PATCH v5 18/27] revisions API: have release_revisions() release "cmdline"
- From
Ævar Arnfjörð Bjarmason <avarab@gmail.com>
- Date
- Apr 3, 2022, 14:01 UTC
- Message-ID
- <220403.86ee2emfgs.gmgdl@evledraar.gmail.com>
- In-Reply-To
- <02da5550-3137-b579-93c5-bf245a8cbc2a@gmail.com>
On Sun, Apr 03 2022, Phillip Wood wrote:
Show 14 quoted lines
> Hi Ævar
>
> On 02/04/2022 11:49, Ævar Arnfjörð Bjarmason wrote:
>> +static void release_revisions_cmdline(struct rev_cmdline_info
>> *cmdline)
>> +{
>> + unsigned int i;
>> +
>> + if (!cmdline)
>> + return;
>
> I don't think we need this guard, the only instances of struct
> rev_cmdline_info exist within struct rev_info, as far as I can see it
> is never created on its own.Yes, it won't ever be NULL. I'll fix that (missed it with the other NULL check cargo-culting).
Show 5 quoted lines
>> + for (i = 0; i < cmdline->nr; i++) >> + free((char *)cmdline->rev[i].name); >> + free(cmdline->rev); > > This could just be in release_revisions()
Ditto <220403.86ilrqmflb.gmgdl@evledraar.gmail.com>. I.e. I'd prefer to keep these for readability