Re: [PATCH v6 06/13] pkt-line: add functions to read/write flush terminated packet streams
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Aug 26, 2016, 17:21 UTC
- Message-ID
- <xmqq60qnigyz.fsf@gitster.mtv.corp.google.com>
- In-Reply-To
- <D8C981C6-22F5-4922-BBF7-F71961B3271B@gmail.com>
Lars Schneider <larsxschneider@gmail.com> writes:
Show 5 quoted lines
> OK, what function names would be more clear from your point of view? > > write_packetized_stream_from_fd() > write_packetized_stream_from_buf() > read_packetized_stream_to_buf()
Would
write_packetized_from_fd()
write_packetized_from_buf()
read_packetized_to_buf()be shorter, still understandable, be consistent with the existing convention to name write_/read_ a function that shuffles bytes via a file descriptor, and to the point, perhaps?