Re: [PATCH v6 06/13] pkt-line: add functions to read/write flush terminated packet streams
- From
Lars Schneider <larsxschneider@gmail.com>
- Date
- Aug 29, 2016, 09:43 UTC
- Message-ID
- <64722B90-8C48-409A-8FAC-75DCD4CBACCD@gmail.com>
- In-Reply-To
- <xmqq60qnigyz.fsf@gitster.mtv.corp.google.com>
Show 19 quoted lines
> On 26 Aug 2016, at 19:21, Junio C Hamano <gitster@pobox.com> wrote: > > Lars Schneider <larsxschneider@gmail.com> writes: > >> OK, what function names would be more clear from your point of view? >> >> write_packetized_stream_from_fd() >> write_packetized_stream_from_buf() >> read_packetized_stream_to_buf() > > Would > > write_packetized_from_fd() > write_packetized_from_buf() > read_packetized_to_buf() > > be shorter, still understandable, be consistent with the existing > convention to name write_/read_ a function that shuffles bytes via a > file descriptor, and to the point, perhaps?
Agreed.
Thanks, Lars