git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v5.1] lib-submodule-update: pass 'test_must_fail' as an argument

From
Junio C Hamano <gitster@pobox.com>
Date
Jun 23, 2020, 23:54 UTC
Message-ID
<xmqq4kr1bao8.fsf@gitster.c.googlers.com>
In-Reply-To
<7b9c19b3606f31b12a79591a41847dcb0a071751.1592942452.git.liu.denton@gmail.com>
Denton Liu <liu.denton@gmail.com> writes:
Show 11 quoted lines
> When $command is a helper function, the parent function calling
> test_submodule_switch_common() is test_submodule_switch_func(). For all
> test_submodule_switch_func() invocations, increase the granularity of
> the argument test helper function by prefixing the git invocation which is
> meant to fail with the second argument like this:
>
> 	$2 git checkout "$1"
>
> ...
> Finally, as an added bonus, `test_must_fail` will now only run on git
> commands.
> This patch replaces v5 4/4. Hopefully, this'll be the last iteration...
So three copies of v5.1 are identical replacement for 4/4, they seem.
> -			test_must_fail $command replace_sub1_with_directory &&
> +			$command replace_sub1_with_directory test_must_fail &&
Show 11 quoted lines
> +# The following example uses `git some-command` as an example command to be
> +# tested. It updates the worktree and index to match a target, but not any
> +# submodule directories.
>  #
>  # my_func () {
> +#   ...prepare for `git some-command` to be run...
> +#   $2 git some-command "$1" &&
> +#   if test -n "$2"
> +#   then
> +#     return
> +#   fi &&

So, in practice $2 MUST BE either test_must_fail OR an empty string. Feeding the my_func anything other than these two values is a BUG. I wonder if we can somehow make sure to reduce mental burden by readers. Perhaps

> +git_test_func () {
	may_only_be_test_must_fail "$2"
> +	$2 git $gitcmd "$1"
> +}
where
	may_only_be_test_must_fail () {
		test -z "$1" || test "$1" = test_must_fail || die
	}

or something. The idea is to make sure that this extra helper can be named in such a way that it can serve as a documention to help readers of "git_test_func ()" and others about "$2".

Show 10 quoted lines
> diff --git a/t/t3426-rebase-submodule.sh b/t/t3426-rebase-submodule.sh
> index 788605ccc0..dd5daa53d3 100755
> --- a/t/t3426-rebase-submodule.sh
> +++ b/t/t3426-rebase-submodule.sh
> @@ -17,7 +17,7 @@ git_rebase () {
>  	git status -su >actual &&
>  	ls -1pR * >>actual &&
>  	test_cmp expect actual &&
> -	git rebase "$1"
> +	$2 git rebase "$1"
Likewise here.

Even without such a change this round reads much better than the previous ones.

> An alternate design was considered where the global variable,
> $OVERWRITING_FAIL, is set from test_submodule_switch_common() and
> exposed to the helper function.  This would allow $command to be
> set to a more sensible value. However ...

By the way, I do not think this paragraph adds much value to the message. It wasn't clear how OVERWRITING_FAIL wanted to achieve its goal back in its own commit, and without any actual code but with only the four lines to go by, there is no chance that you can convince anybody how $command could have been "more sensible value".

Thanks.
Previous: Denton LiuNext: Đoàn Trần Công Danh
Message 61 of 64 in “t: replace incorrect test_must_fail usage (part 5)”
  1. 0/4 t: replace incorrect test_must_fail usage (part 5)Denton Liu, Apr 29, 2020
  2. 1/4 lib-submodule-update: add space after function nameDenton Liu, Apr 29, 2020
  3. 3/4 lib-submodule-update: prepend "git" to $commandDenton Liu, Apr 29, 2020
  4. 2/4 lib-submodule-update: consolidate --recurse-submodulesDenton Liu, Apr 29, 2020
  5. Junio C HamanoApr 29, 2020
  6. 4/4 lib-submodule-update: pass OVERWRITING_FAILDenton Liu, Apr 29, 2020
  7. Junio C HamanoApr 29, 2020
  8. Denton LiuApr 30, 2020
  9. Junio C HamanoApr 30, 2020
  10. Denton LiuApr 30, 2020
  11. lib-submodule-update: pass OVERWRITING_FAILDenton Liu, Apr 30, 2020
  12. Junio C HamanoApr 30, 2020
  13. Denton LiuMay 1, 2020
  14. Junio C HamanoMay 1, 2020
  15. lib-submodule-update: pass OVERWRITING_FAILDenton Liu, May 5, 2020
  16. Taylor BlauApr 29, 2020
  17. Johannes SixtApr 29, 2020
  18. Re* [PATCH 0/4] t: replace incorrect test_must_fail usage (part 5)Junio C Hamano, Apr 29, 2020
  19. Taylor BlauApr 29, 2020
  20. Junio C HamanoApr 29, 2020
  21. Taylor BlauApr 29, 2020
  22. Junio C HamanoApr 29, 2020
  23. Taylor BlauApr 29, 2020
  24. Eric SunshineApr 29, 2020
  25. Junio C HamanoApr 29, 2020
  26. 0/4 t: replace incorrect test_must_fail usage (part 5)Denton Liu, May 21, 2020
  27. 1/4 lib-submodule-update: add space after function nameDenton Liu, May 21, 2020
  28. 2/4 lib-submodule-update: consolidate --recurse-submodulesDenton Liu, May 21, 2020
  29. 3/4 lib-submodule-update: prepend "git" to $commandDenton Liu, May 21, 2020
  30. Philip OakleyMay 21, 2020
  31. Denton LiuMay 21, 2020
  32. 4/4 lib-submodule-update: pass OVERWRITING_FAILDenton Liu, May 21, 2020
  33. Jeff KingMay 21, 2020
  34. Denton LiuMay 21, 2020
  35. Junio C HamanoMay 21, 2020
  36. Jeff KingMay 21, 2020
  37. Jeff KingMay 21, 2020
  38. Junio C HamanoMay 21, 2020
  39. Jeff KingMay 21, 2020
  40. 0/4 t: replace incorrect test_must_fail usage (part 5)Denton Liu, Jun 11, 2020
  41. 1/4 lib-submodule-update: add space after function nameDenton Liu, Jun 11, 2020
  42. 2/4 lib-submodule-update: consolidate --recurse-submodulesDenton Liu, Jun 11, 2020
  43. 3/4 lib-submodule-update: prepend "git" to $commandDenton Liu, Jun 11, 2020
  44. 4/4 lib-submodule-update: use callbacks in test_submodule_switch_common()Denton Liu, Jun 11, 2020
  45. Junio C HamanoJun 12, 2020
  46. Junio C HamanoJun 18, 2020
  47. 0/4 t: replace incorrect test_must_fail usage (part 5)Denton Liu, Jun 18, 2020
  48. 1/4 lib-submodule-update: add space after function nameDenton Liu, Jun 18, 2020
  49. 2/4 lib-submodule-update: consolidate --recurse-submodulesDenton Liu, Jun 18, 2020
  50. 3/4 lib-submodule-update: prepend "git" to $commandDenton Liu, Jun 18, 2020
  51. 4/4 lib-submodule-update: use callbacks in test_submodule_switch_common()Denton Liu, Jun 18, 2020
  52. Jeff KingJun 18, 2020
  53. 0/4 t: replace incorrect test_must_fail usage (part 5)Denton Liu, Jun 23, 2020
  54. 1/4 lib-submodule-update: add space after function nameDenton Liu, Jun 23, 2020
  55. 2/4 lib-submodule-update: consolidate --recurse-submodulesDenton Liu, Jun 23, 2020
  56. 4/4 lib-submodule-update: use callbacks in test_submodule_switch_common()Denton Liu, Jun 23, 2020
  57. 3/4 lib-submodule-update: prepend "git" to $commandDenton Liu, Jun 23, 2020
  58. Jeff KingJun 23, 2020
  59. lib-submodule-update: pass 'test_must_fail' as an argumentDenton Liu, Jun 23, 2020
  60. lib-submodule-update: pass 'test_must_fail' as an argumentDenton Liu, Jun 23, 2020
  61. Junio C HamanoJun 23, 2020
  62. Đoàn Trần Công DanhJun 24, 2020
  63. lib-submodule-update: pass 'test_must_fail' as an argumentDenton Liu, Jun 24, 2020
  64. Junio C HamanoJun 24, 2020

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.