Re: [PATCH v4 4/4] init: provide useful advice about init.defaultBranch
- From
Johannes Schindelin <johannes.schindelin@gmx.de>
- Date
- Dec 11, 2020, 00:47 UTC
- Message-ID
- <nycvar.QRO.7.76.6.2012110145200.25979@tvgsbejvaqbjf.bet>
- In-Reply-To
- <xmqq360dqgpa.fsf@gitster.c.googlers.com>
Hi Junio,
On Thu, 10 Dec 2020, Junio C Hamano wrote:
Show 22 quoted lines
> Felipe Contreras <felipe.contreras@gmail.com> writes: > > > On Thu, Dec 10, 2020 at 3:58 PM Johannes Schindelin via GitGitGadget > > <gitgitgadget@gmail.com> wrote: > > > >> +static const char default_branch_name_advice[] = N_( > >> +"Using '%s' as the name for the initial branch. This default branch name\n" > >> +"is subject to change. To configure the initial branch name to use in all\n" > >> +"of your new repositories, which will suppress this warning, call:\n" > >> +"\n" > >> +"\tgit config --global init.defaultBranch <name>\n" > >> +"\n" > >> +"Common names are 'main', 'trunk' and 'development'. The initial branch\n" > > > > This is disingenuous; the most common name is "master"... by far. In a > > couple years this might change, but not right now. > > > > If you don't want to mention "master", then don't mention "common > > names" that are not really the most common names. > > Names commonly chosen by those who want to move away from 'master' > are...
"those who want to move away" sounds a bit too non-committal for my liking. So I changed it to:
Names commonly chosen instead of 'master' are 'main', 'trunk' and 'development'.
While at it, I also improved the next sentence:
The just-created branch can be renamed via this command:
Ciao, Dscho