Re: [PATCH v4 4/4] init: provide useful advice about init.defaultBranch
- From
Felipe Contreras <felipe.contreras@gmail.com>
- Date
- Dec 11, 2020, 00:15 UTC
- Message-ID
- <CAMP44s0mEsfmc7gT6Yv10_nt8d=HrbETmnwNNqxVmRGdHSOHYw@mail.gmail.com>
- In-Reply-To
- <2f21c505d560132b4563849f955554fc7d79a9cb.1607637517.git.gitgitgadget@gmail.com>
On Thu, Dec 10, 2020 at 3:58 PM Johannes Schindelin via GitGitGadget <gitgitgadget@gmail.com> wrote:
Show 8 quoted lines
> +static const char default_branch_name_advice[] = N_( > +"Using '%s' as the name for the initial branch. This default branch name\n" > +"is subject to change. To configure the initial branch name to use in all\n" > +"of your new repositories, which will suppress this warning, call:\n" > +"\n" > +"\tgit config --global init.defaultBranch <name>\n" > +"\n" > +"Common names are 'main', 'trunk' and 'development'. The initial branch\n"
This is disingenuous; the most common name is "master"... by far. In a couple years this might change, but not right now.
If you don't want to mention "master", then don't mention "common names" that are not really the most common names.
Cheers.
-- Felipe Contreras