Re: Cleaning up git user-interface warts
- From
Jakub Narebski <jnareb@gmail.com>
- Date
- Nov 14, 2006, 21:01 UTC
- Message-ID
- <ejdapj$vc0$1@sea.gmane.org>
- In-Reply-To
- <Pine.LNX.4.64.0611141518590.2591@xanadu.home>
Nicolas Pitre wrote:
Show 11 quoted lines
> If the fetch+merge behavior (which I think should really be refered as > pull+merge) is still desirable, then it should be called git-update and > be no more than a single shell script line such as > > git_pull && git_merge" > > This is really what most people expect from such a command name based > on obvious historical reasons. The lack of any branch argument to > git-pull and git-merge could be defined as using the first defined > remote branch by default. But having git-pull performing merges is IMHO > overloading the word and goes against most people's expectations.
By the way, is anyone doing _remote_ octopus pull (true pull, not with . as repository)?
We can always have --merge arguments to git-pull, and --fetch argument to git-merge.
-- Jakub Narebski Warsaw, Poland ShadeHawk on #git