Re: Cleaning up git user-interface warts
- From
Johannes Schindelin <johannes.schindelin@gmx.de>
- Date
- Nov 15, 2006, 14:01 UTC
- Message-ID
- <Pine.LNX.4.63.0611151454250.13772@wbgn013.biozentrum.uni-wuerzburg.de>
- In-Reply-To
- <7vu011qnl6.fsf@assigned-by-dhcp.cox.net>
Hi,
On Tue, 14 Nov 2006, Junio C Hamano wrote:
Show 5 quoted lines
> Nicolas Pitre <nico@cam.org> writes: > > > 1) make "git init" an alias for "git init-db". > > Or even better, have "gh init".
Please no. It only makes things even more confusing. "git init" is perfect as it is. We can always have internal aliases from "init-db" to "init" to account for older usages.
Show 6 quoted lines
> > 2) "pull" and "push" should be symmetrical operations > > I think that makes a lot of sense to have "gh pull" and "gh > push" as symmetric operations, and make "gh merge" do the > fast-forward and 3-way merge magic done in the current "git > pull". These three words would have a lot saner meaning.
I am really opposed to do "gh pull". Not only because of "gh" being completely confusing (we already _have_ "git", and for porcelains different TLAs), but "pull" _really_ is confusing by now. And Mercurial did not help one wit by insisting on their own interpretation.
Why not do something like "get/put" instead? It is
- easier to remember - not bogus (AFAICT the meaning is not used in diametrical senses) - shorter to type than download/upload
As for "git merge": Just by the number of arguments you can discern between the original usage and the new usage, so I am all in favour of replacing "git pull <blabla>" by "git merge <blabla>". Where "<blabla>" can be a branch or a remote or a URL (with cogito style #branchname).
Ciao, Dscho