Re: Cleaning up git user-interface warts
- From
Alan Chandler <alan@chandlerfamily.org.uk>
- Date
- Nov 18, 2006, 11:09 UTC
- Message-ID
- <200611181109.14675.alan@chandlerfamily.org.uk>
- In-Reply-To
- <Pine.LNX.4.64.0611151023160.2591@xanadu.home>
On Wednesday 15 November 2006 15:41, Nicolas Pitre wrote:
Show 21 quoted lines
> On Wed, 15 Nov 2006, Andy Parkins wrote: > > * Don't use the name "origin" twice. In fact, don't use it at all. In > > a distributed system there is no such thing as a true origin. > > I agree, sort of. Not because"origin" is ambigous as a name. But > rather because there is a magic translation from "master" to "origin", > and I think this is wrong to do that. > > As mentioned elsewhere (and let's start using "get" instead of "pull" as > suggested by Johannes), a "get" should probably always create a branch > group even if it contains only one branch. This way the remote branch > called "master" will still be called "master" locally, under the branch > group used to represent the remote repository. And if a local name is > not provided then let's just call it "default". This way, amongst the > remote references, there would be a "default/master" that would be used > when nothing else is provided by the user. So... > > git get repo.com/time_machine.git > > would create a local branch named "remotes/default/master" if the remote > repo has only a master branch.
Why not call it remotes/repo.com/time_machine.git/master and have a DEFAULT_ORIGIN that is a symref to it in the same way as HEAD is a symref to a local branch
-- Alan Chandler