Re: [PATCH v2 4/9] rebase -i: refactor transform_todo_ids
- From
liam Beguin <liambeguin@gmail.com>
- Date
- Dec 5, 2017, 03:39 UTC
- Message-ID
- <edf23a51-f08d-6e61-b1a5-af8929c477ab@gmail.com>
- In-Reply-To
- <alpine.DEB.2.21.1.1712041541000.98586@virtualbox>
Hi Johannes,
On 04/12/17 09:42 AM, Johannes Schindelin wrote:
Show 12 quoted lines
> Hi Liam, > > On Sun, 3 Dec 2017, Liam Beguin wrote: > >> The transform_todo_ids function is a little hard to read. Lets try >> to make it easier by using more of the strbuf API. Also, since we'll >> soon be adding command abbreviations, let's rename the function so >> it's name reflects that change. > > I am not really a fan of the new name, and would prefer the old one, but > that's only a nit, not a reason to reject the patch. >
You're right, it's probably not the best name. I'll change it to transform_todos() as we want the function name to reflect that it changes both parts of the todo.
> The rest of it makes the code reads a lot nicer than before. Thank you, > Johannes >
Thanks, Liam