Re: [PATCH v2 0/9] rebase -i: add config to abbreviate command names
- From
Johannes Schindelin <johannes.schindelin@gmx.de>
- Date
- Dec 4, 2017, 16:07 UTC
- Message-ID
- <alpine.DEB.2.21.1.1712041707050.98586@virtualbox>
- In-Reply-To
- <20171203221721.16462-1-liambeguin@gmail.com>
Hi Liam,
On Sun, 3 Dec 2017, Liam Beguin wrote:
Show 22 quoted lines
> This series will add the 'rebase.abbreviateCommands' configuration > option to allow `git rebase -i` to default to the single-letter command > names when generating the todo list. > > Using single-letter command names can present two benefits. First, it > makes it easier to change the action since you only need to replace a > single character (i.e.: in vim "r<character>" instead of > "ciw<character>"). Second, using this with a large enough value of > 'core.abbrev' enables the lines of the todo list to remain aligned > making the files easier to read. > > Changes in V2: > - Refactor and rename 'transform_todo_ids' > - Replace SHA-1 by OID in rebase--helper.c > - Update todo list related functions to take a generic 'flags' parameter > - Rename 'add_exec_commands' function to 'sequencer_add_exec_commands' > - Rename 'add-exec' option to 'add-exec-commands' > - Use 'strbur_read_file' instead of rewriting it > - Make 'command_to_char' return 'comment_char_line' if no single-letter > command name is defined > - Combine both tests into a single test case > - Update commit messages
Looks very nice already! I offered a couple of comments/suggestions, but nothing major.
Thank you, Johannes