Re: [PATCH v2 4/9] rebase -i: refactor transform_todo_ids
- From
Johannes Schindelin <johannes.schindelin@gmx.de>
- Date
- Dec 4, 2017, 14:42 UTC
- Message-ID
- <alpine.DEB.2.21.1.1712041541000.98586@virtualbox>
- In-Reply-To
- <20171203221721.16462-5-liambeguin@gmail.com>
Hi Liam,
On Sun, 3 Dec 2017, Liam Beguin wrote:
> The transform_todo_ids function is a little hard to read. Lets try > to make it easier by using more of the strbuf API. Also, since we'll > soon be adding command abbreviations, let's rename the function so > it's name reflects that change.
I am not really a fan of the new name, and would prefer the old one, but that's only a nit, not a reason to reject the patch.
The rest of it makes the code reads a lot nicer than before. Thank you, Johannes