Re: [PATCH 3/3] compat/mingw: support POSIX semantics for atomic renames
- From
- Kristoffer Haugsbakk <kristofferhaugsbakk@fastmail.com>
- Date
- Oct 24, 2024, 07:18 UTC
- Message-ID
- <d6669573-d5cc-4ad9-b248-95bda089bc6c@app.fastmail.com>
- In-Reply-To
- <ZxnpitkbPPNTLuGT@pks.im>
On Thu, Oct 24, 2024, at 08:30, Patrick Steinhardt wrote:
Show 11 quoted lines
>> s/FILE_RENAME_POSIX_SEMANICS/FILE_RENAME_FLAG_POSIX_SEMANTICS/ > > No, this is actually intentional. There are two different flags: > > - FILE_RENAME_POSIX_SEMANTICS is what ntifs.h exposes and what I've > been linking for documentation. This flag cannot be used though with > `FileRenameInfoEx`. > > - FILE_RENAME_FLAG_POSIX_SEMANTICS is what needs to be used with > `FileRenameInfoEx`, but it is undocumented. >
I made a copy–paste mistake. :P I should have just pointed out this (missing T):
_SEMANICS
So you wrote it the correct-looking way in your first bullet point here.