Re: [PATCH 3/3] compat/mingw: support POSIX semantics for atomic renames
- From
- Kristoffer Haugsbakk <kristofferhaugsbakk@fastmail.com>
- Date
- Oct 23, 2024, 16:19 UTC
- Message-ID
- <51b63d57-fa01-4a8c-95fa-770a62afd80f@app.fastmail.com>
- In-Reply-To
- <d17ca1c7ce38e12fe113f15b078c12bc92e8f0aa.1729695349.git.ps@pks.im>
On Wed, Oct 23, 2024, at 17:05, Patrick Steinhardt wrote:
> […] > Careful readers might have noticed that [1] does not mention the above > flag, but instead mentions `FILE_RENAME_POSIX_SEMANICS`. This flag is
s/FILE_RENAME_POSIX_SEMANICS/FILE_RENAME_FLAG_POSIX_SEMANTICS/
Show 5 quoted lines
> not for use with `SetFileInformationByHandle()` though, which is what we > use. And while the `FILE_RENAME_FLAG_POSIX_SEMANTICS` flag exists, it is > not documented on [2] or anywhere else as far as I can tell. > > Unfortuntaly, we still support Windows systems older than Windows 10
s/Unfortuntaly/Unfortunately/
Show 6 quoted lines
> […] > > On another note: `mingw_rename()` has a retry loop that is used in case > deleting a file failed because it's still open in another process. One > might be pressed to not use this loop anymore when we can use POSIX > semantics. But unfortuntaley, we have to keep it around due to our
s/unfortuntaley/unfortunately/
Show 13 quoted lines
> [1]: > https://learn.microsoft.com/en-us/windows-hardware/drivers/ddi/ntifs/ns-ntifs-_file_rename_information > [2]: > https://learn.microsoft.com/en-us/windows/win32/api/winbase/ns-winbase-file_rename_info > > Signed-off-by: Patrick Steinhardt <ps@pks.im> > --- > compat/mingw.c | 87 ++++++++++++++++++++++++++++++++++++-- > t/t0610-reftable-basics.sh | 8 ++-- > 2 files changed, 88 insertions(+), 7 deletions(-) > […] > + > /* TODO: translate more errors */
It seems that `Documentation` doesn’t mention the difference between `TODO` and `NEEDSWORK`. What is it?
> […] > -- > 2.47.0.118.gfd3785337b.dirty