Re: [PATCH 3/3] compat/mingw: support POSIX semantics for atomic renames
On Wed, Oct 23, 2024 at 06:19:43PM +0200, Kristoffer Haugsbakk wrote:
Show 6 quoted lines
> On Wed, Oct 23, 2024, at 17:05, Patrick Steinhardt wrote:
> > […]
> > Careful readers might have noticed that [1] does not mention the above
> > flag, but instead mentions `FILE_RENAME_POSIX_SEMANICS`. This flag is
>
> s/FILE_RENAME_POSIX_SEMANICS/FILE_RENAME_FLAG_POSIX_SEMANTICS/
No, this is actually intentional. There are two different flags:
- FILE_RENAME_POSIX_SEMANTICS is what ntifs.h exposes and what I've
been linking for documentation. This flag cannot be used though with
`FileRenameInfoEx`. - FILE_RENAME_FLAG_POSIX_SEMANTICS is what needs to be used with
`FileRenameInfoEx`, but it is undocumented.> > /* TODO: translate more errors */
>
> It seems that `Documentation` doesn’t mention the difference between
> `TODO` and `NEEDSWORK`. What is it?
No idea, to be honest.
Patrick