git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH 0/4] rename "sha1-foo" files

From
MÅMartin Ågren <martin.agren@gmail.com>
Date
Dec 29, 2020, 23:52 UTC
Message-ID
<cover.1609282997.git.martin.agren@gmail.com>

We have some source files with filenames such as sha1-lookup.c and sha1-name.c containing a few variable names, comments and the like referencing "sha1". But they are able to handle SHA-256 as well. Here's my attempt at removing "sha1" from the contents and names of these files.

Martin Ågren (4):
  object-name.c: rename from sha1-name.c
  object-file.c: rename from sha1-file.c
  sha1-lookup: rename `sha1_pos()` as `hash_pos()`
  hash-lookup: rename from sha1-lookup
 t/oid-info/README              |  2 +-
 sha1-lookup.h => hash-lookup.h | 14 +++++++-------
 bisect.c                       |  2 +-
 builtin/index-pack.c           |  2 +-
 builtin/name-rev.c             |  4 ++--
 commit-graph.c                 |  8 ++++----
 commit.c                       |  4 ++--
 sha1-lookup.c => hash-lookup.c | 22 +++++++++++-----------
 list-objects-filter.c          |  2 +-
 midx.c                         |  2 +-
 sha1-file.c => object-file.c   |  4 ++--
 sha1-name.c => object-name.c   | 14 +++++++-------
 oid-array.c                    |  4 ++--
 pack-bitmap-write.c            |  4 ++--
 packfile.c                     |  2 +-
 patch-ids.c                    |  2 +-
 rerere.c                       |  4 ++--
 Makefile                       |  6 +++---
 18 files changed, 51 insertions(+), 51 deletions(-)
 rename sha1-lookup.h => hash-lookup.h (72%)
 rename sha1-lookup.c => hash-lookup.c (84%)
 rename sha1-file.c => object-file.c (99%)
 rename sha1-name.c => object-name.c (99%)
-- 
2.30.0
Next: Martin Ågren
Message 1 of 19 in “rename "sha1-foo" files”
  1. 0/4 rename "sha1-foo" filesMartin Ågren, Dec 29, 2020
  2. 1/4 object-name.c: rename from sha1-name.cMartin Ågren, Dec 29, 2020
  3. Derrick StoleeDec 30, 2020
  4. 2/4 object-file.c: rename from sha1-file.cMartin Ågren, Dec 29, 2020
  5. 3/4 sha1-lookup: rename `sha1_pos()` as `hash_pos()`Martin Ågren, Dec 29, 2020
  6. Derrick StoleeDec 30, 2020
  7. 4/4 hash-lookup: rename from sha1-lookupMartin Ågren, Dec 29, 2020
  8. Derrick StoleeDec 30, 2020
  9. Martin ÅgrenDec 30, 2020
  10. Derrick StoleeDec 30, 2020
  11. brian m. carlsonDec 30, 2020
  12. Martin ÅgrenDec 30, 2020
  13. 0/4 rename "sha1-foo" filesMartin Ågren, Dec 31, 2020
  14. 1/4 object-name.c: rename from sha1-name.cMartin Ågren, Dec 31, 2020
  15. 2/4 object-file.c: rename from sha1-file.cMartin Ågren, Dec 31, 2020
  16. 3/4 sha1-lookup: rename `sha1_pos()` as `hash_pos()`Martin Ågren, Dec 31, 2020
  17. 4/4 hash-lookup: rename from sha1-lookupMartin Ågren, Dec 31, 2020
  18. Derrick StoleeDec 31, 2020
  19. Martin ÅgrenDec 31, 2020

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.