git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 1/4] object-name.c: rename from sha1-name.c

From
Derrick Stolee <stolee@gmail.com>
Date
Dec 30, 2020, 01:19 UTC
Message-ID
<7cc9ac55-1e9a-05ed-fde6-a422804ed3b9@gmail.com>
In-Reply-To
<aac3a3c3e202f790f11089e2c8f814bea9943831.1609282997.git.martin.agren@gmail.com>
On 12/29/2020 6:52 PM, Martin Ågren wrote:
Show 10 quoted lines
> Generalize the last remnants of "sha" and "sha1" in this file and rename
> it to reflect that we're not just able to handle SHA-1 these days.
> 
> Signed-off-by: Martin Ågren <martin.agren@gmail.com>
> ---
>  list-objects-filter.c        |  2 +-
>  sha1-name.c => object-name.c | 14 +++++++-------
>  Makefile                     |  2 +-
>  3 files changed, 9 insertions(+), 9 deletions(-)
>  rename sha1-name.c => object-name.c (99%)

I was tempted to recommend making the content changes to sha1-name.c in a preperatory patch then doing a patch that preforms an exact rename (along with edits to Makefile and list-objects-filter.c).

However, I talked myself out of it while writing this
response. Having an exact rename won't materially change
how "git log --follow" or "git blame" behave.
 
Thanks,
-Stolee
Previous: Martin ÅgrenNext: Martin Ågren
Message 3 of 19 in “rename "sha1-foo" files”
  1. 0/4 rename "sha1-foo" filesMartin Ågren, Dec 29, 2020
  2. 1/4 object-name.c: rename from sha1-name.cMartin Ågren, Dec 29, 2020
  3. Derrick StoleeDec 30, 2020
  4. 2/4 object-file.c: rename from sha1-file.cMartin Ågren, Dec 29, 2020
  5. 3/4 sha1-lookup: rename `sha1_pos()` as `hash_pos()`Martin Ågren, Dec 29, 2020
  6. Derrick StoleeDec 30, 2020
  7. 4/4 hash-lookup: rename from sha1-lookupMartin Ågren, Dec 29, 2020
  8. Derrick StoleeDec 30, 2020
  9. Martin ÅgrenDec 30, 2020
  10. Derrick StoleeDec 30, 2020
  11. brian m. carlsonDec 30, 2020
  12. Martin ÅgrenDec 30, 2020
  13. 0/4 rename "sha1-foo" filesMartin Ågren, Dec 31, 2020
  14. 1/4 object-name.c: rename from sha1-name.cMartin Ågren, Dec 31, 2020
  15. 2/4 object-file.c: rename from sha1-file.cMartin Ågren, Dec 31, 2020
  16. 3/4 sha1-lookup: rename `sha1_pos()` as `hash_pos()`Martin Ågren, Dec 31, 2020
  17. 4/4 hash-lookup: rename from sha1-lookupMartin Ågren, Dec 31, 2020
  18. Derrick StoleeDec 31, 2020
  19. Martin ÅgrenDec 31, 2020

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.