git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 0/4] rename "sha1-foo" files

From
Derrick Stolee <stolee@gmail.com>
Date
Dec 30, 2020, 13:35 UTC
Message-ID
<cb9ef187-5b61-431d-f540-4adc1bc8ad9b@gmail.com>
In-Reply-To
<CAN0heSq2ttahii+tUJo92L0ERcbYuS-Z51OhMsQsd-a51SWPKQ@mail.gmail.com>
On 12/30/2020 3:01 AM, Martin Ågren wrote:
Show 12 quoted lines
> On Wed, 30 Dec 2020 at 02:29, Derrick Stolee <stolee@gmail.com> wrote:
>> Oh, and I remembered the one semi-legitimate case to try for exact
>> renames whenever possible: "git log --follow" will download fewer
>> blobs in a blobless partial clone (--filter=blob:none). Of course,
>> this only works if the rule is always followed and is not really a
>> justification for doubling the number of your patches.
> 
> Ok, I see. Well, if you and/or others feel we should aim for a 100%
> rename, I don't mind splitting the patches. My gut reaction is along
> your "only works if the rule is always followed", plus I wonder if there
> are actually Git developers using a blobless partial clone of git.git
> [other than for testing blobless partial clones].

The upside is so small, it is not worth re-rolling your series. I was just thinking out loud to justify my first gut reaction. Even in blobless clones, this is not a huge cost (as long as we didn't also add or remove enormous blobs). This behavior of "filling in the gaps" is expected we use the repository.

Thanks, -Stolee

Previous: Martin ÅgrenNext: brian m. carlson
Message 10 of 19 in “rename "sha1-foo" files”
  1. 0/4 rename "sha1-foo" filesMartin Ågren, Dec 29, 2020
  2. 1/4 object-name.c: rename from sha1-name.cMartin Ågren, Dec 29, 2020
  3. Derrick StoleeDec 30, 2020
  4. 2/4 object-file.c: rename from sha1-file.cMartin Ågren, Dec 29, 2020
  5. 3/4 sha1-lookup: rename `sha1_pos()` as `hash_pos()`Martin Ågren, Dec 29, 2020
  6. Derrick StoleeDec 30, 2020
  7. 4/4 hash-lookup: rename from sha1-lookupMartin Ågren, Dec 29, 2020
  8. Derrick StoleeDec 30, 2020
  9. Martin ÅgrenDec 30, 2020
  10. Derrick StoleeDec 30, 2020
  11. brian m. carlsonDec 30, 2020
  12. Martin ÅgrenDec 30, 2020
  13. 0/4 rename "sha1-foo" filesMartin Ågren, Dec 31, 2020
  14. 1/4 object-name.c: rename from sha1-name.cMartin Ågren, Dec 31, 2020
  15. 2/4 object-file.c: rename from sha1-file.cMartin Ågren, Dec 31, 2020
  16. 3/4 sha1-lookup: rename `sha1_pos()` as `hash_pos()`Martin Ågren, Dec 31, 2020
  17. 4/4 hash-lookup: rename from sha1-lookupMartin Ågren, Dec 31, 2020
  18. Derrick StoleeDec 31, 2020
  19. Martin ÅgrenDec 31, 2020

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.