git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 0/4] rename "sha1-foo" files

From
Derrick Stolee <stolee@gmail.com>
Date
Dec 30, 2020, 01:29 UTC
Message-ID
<4d1f5c59-db2c-3c88-f3ca-1edcdfb2f99e@gmail.com>
In-Reply-To
<cover.1609282997.git.martin.agren@gmail.com>
On 12/29/2020 6:52 PM, Martin Ågren wrote:
Show 5 quoted lines
> We have some source files with filenames such as sha1-lookup.c and
> sha1-name.c containing a few variable names, comments and the like
> referencing "sha1". But they are able to handle SHA-256 as well. Here's
> my attempt at removing "sha1" from the contents and names of these
> files.

I think this is a good effort. Timing is good after the v2.30.0 release. As long as this doesn't conflict drastically with things in flight, I think this change should "jump the line" and merge with priority to avoid future conflicts.

It _has_ been bothering me that it was still sha1-file.c.

Oh, and I remembered the one semi-legitimate case to try for exact renames whenever possible: "git log --follow" will download fewer blobs in a blobless partial clone (--filter=blob:none). Of course, this only works if the rule is always followed and is not really a justification for doubling the number of your patches.

It does make me think that it is worth checking if "git log --follow" short-circuits the full rename detection if the path it cares about was found to be an exact rename (so doing a full content-rename check on the other adds and deletes is worthless). Making a note [1] to investigate.

[1] https://github.com/gitgitgadget/git/issues/827

Thanks, -Stolee

Previous: Martin ÅgrenNext: Martin Ågren
Message 8 of 19 in “rename "sha1-foo" files”
  1. 0/4 rename "sha1-foo" filesMartin Ågren, Dec 29, 2020
  2. 1/4 object-name.c: rename from sha1-name.cMartin Ågren, Dec 29, 2020
  3. Derrick StoleeDec 30, 2020
  4. 2/4 object-file.c: rename from sha1-file.cMartin Ågren, Dec 29, 2020
  5. 3/4 sha1-lookup: rename `sha1_pos()` as `hash_pos()`Martin Ågren, Dec 29, 2020
  6. Derrick StoleeDec 30, 2020
  7. 4/4 hash-lookup: rename from sha1-lookupMartin Ågren, Dec 29, 2020
  8. Derrick StoleeDec 30, 2020
  9. Martin ÅgrenDec 30, 2020
  10. Derrick StoleeDec 30, 2020
  11. brian m. carlsonDec 30, 2020
  12. Martin ÅgrenDec 30, 2020
  13. 0/4 rename "sha1-foo" filesMartin Ågren, Dec 31, 2020
  14. 1/4 object-name.c: rename from sha1-name.cMartin Ågren, Dec 31, 2020
  15. 2/4 object-file.c: rename from sha1-file.cMartin Ågren, Dec 31, 2020
  16. 3/4 sha1-lookup: rename `sha1_pos()` as `hash_pos()`Martin Ågren, Dec 31, 2020
  17. 4/4 hash-lookup: rename from sha1-lookupMartin Ågren, Dec 31, 2020
  18. Derrick StoleeDec 31, 2020
  19. Martin ÅgrenDec 31, 2020

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.