[PATCH v2 1/8] reset: rename update_refs to reset_refs
- From
Brad King <brad.king@kitware.com>
- Date
- Aug 30, 2013, 18:11 UTC
- Message-ID
- <ce57e08b2fe53b23ba3627bc8a9e0cc44a7683e2.1377885441.git.brad.king@kitware.com>
- In-Reply-To
- <cover.1377885441.git.brad.king@kitware.com>
The function resets refs rather than doing arbitrary updates. Rename it to allow a future general-purpose update_refs function to be added.
Signed-off-by: Brad King <brad.king@kitware.com> --- builtin/reset.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/builtin/reset.c b/builtin/reset.c index afa6e02..789ee48 100644 --- a/builtin/reset.c +++ b/builtin/reset.c @@ -219,7 +219,7 @@ static const char **parse_args(const char **argv, const char *prefix, const char return argv[0] ? get_pathspec(prefix, argv) : NULL; } -static int update_refs(const char *rev, const unsigned char *sha1) +static int reset_refs(const char *rev, const unsigned char *sha1) { int update_ref_status; struct strbuf msg = STRBUF_INIT; @@ -350,7 +350,7 @@ int cmd_reset(int argc, const char **argv, const char *prefix) if (!pathspec && !unborn) { /* Any resets without paths update HEAD to the head being * switched to, saving the previous head in ORIG_HEAD before. */ - update_ref_status = update_refs(rev, sha1); + update_ref_status = reset_refs(rev, sha1); if (reset_type == HARD && !update_ref_status && !quiet) print_new_head_line(lookup_commit_reference(sha1));
-- 1.7.10.4